gnu: Add libusb@0.1.

* gnu/packages/libusb.scm (libusb-0.1): New variable.
* gnu/packages/patches/libusb-0.1-disable-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
This commit is contained in:
Jonathan Brielmaier 2017-07-14 00:28:14 +02:00 committed by Marius Bakke
parent 7c0d4c3a6b
commit 05c8851695
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 32 additions and 0 deletions

View File

@ -793,6 +793,7 @@ dist_patch_DATA = \
%D%/packages/patches/libtorrent-rasterbar-boost-compat.patch \
%D%/packages/patches/libtool-skip-tests2.patch \
%D%/packages/patches/libunwind-CVE-2015-3239.patch \
%D%/packages/patches/libusb-0.1-disable-tests.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
%D%/packages/patches/libxcb-python-3.5-compat.patch \
%D%/packages/patches/libxml2-CVE-2016-4658.patch \

View File

@ -5,6 +5,7 @@
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@ -95,6 +96,21 @@ devices on various operating systems.")
version of libusb to run with newer libusb.")
(license lgpl2.1+)))
;; required by 0xffff, which compiles with libusb-compat, but executes only
;; with libusb-0.1
(define-public libusb-0.1
(package (inherit libusb)
(version "0.1.12")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libusb/libusb-0.1 (LEGACY)/"
version "/libusb-" version ".tar.gz"))
(sha256
(base32
"0i4bacxkyr7xyqxbmb00ypkrv4swkgm0mghbzjsnw6blvvczgxip"))
(patches (search-patches "libusb-0.1-disable-tests.patch"))))))
(define-public libusb4java
;; There is no public release so we take the latest version from git.
(let ((commit "396d642a57678a0d9663b062c980fe100cc0ea1e")

View File

@ -0,0 +1,15 @@
Disable tests who fail because they have to run as root.
--- libusb-0.1.12/tests/Makefile.in 2006-03-04 03:54:06.000000000 +0100
+++ libusb-0.1.12/tests/Makefile.in 2017-07-13 16:17:45.201728019 +0200
@@ -255,8 +255,8 @@
hub_strings_LDADD = $(top_builddir)/libusbpp.la @OSLIBS@
driver_name_SOURCES = driver_name.cpp
driver_name_LDADD = $(top_builddir)/libusbpp.la @OSLIBS@
-TESTS = testlibusb descriptor_test id_test find_hubs find_mice \
- get_resolution hub_strings $(OS_SPECIFIC)
+TESTS = testlibusb descriptor_test id_test find_hubs find_mice
+ #get_resolution hub_strings $(OS_SPECIFIC)
XFAIL_TESTS = get_resolution hub_strings $(OS_SPECIFIC_XFAIL)
all: all-am