gnu: plink: Set endian-ness on more architectures.

* gnu/packages/patches/plink-endian-detection.patch: New file.
* gnu/packages/bioinformatics.scm (plink)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
Efraim Flashner 2016-09-22 20:30:36 +03:00
parent c788c5feb1
commit 0dbb7ac2df
No known key found for this signature in database
GPG Key ID: F4C1D3917EACEE93
3 changed files with 33 additions and 1 deletions

View File

@ -745,6 +745,7 @@ dist_patch_DATA = \
%D%/packages/patches/pinball-system-ltdl.patch \
%D%/packages/patches/pingus-sdl-libs-config.patch \
%D%/packages/patches/plink-1.07-unclobber-i.patch \
%D%/packages/patches/plink-endian-detection.patch \
%D%/packages/patches/plotutils-libpng-jmpbuf.patch \
%D%/packages/patches/polkit-drop-test.patch \
%D%/packages/patches/portaudio-audacity-compat.patch \

View File

@ -4279,7 +4279,8 @@ accessed/downloaded on demand across HTTP.")
version "-src.zip"))
(sha256
(base32 "0as8gxm4pjyc8dxmm1sl873rrd7wn5qs0l29nqfnl31x8i467xaa"))
(patches (search-patches "plink-1.07-unclobber-i.patch"))))
(patches (search-patches "plink-1.07-unclobber-i.patch"
"plink-endian-detection.patch"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;no "check" target

View File

@ -0,0 +1,30 @@
This patch is borrowed from Debian's patches for plink
Author: Peter Green <plugwash@p10link.net>
Puropose: Fallback to endian.h if all else fails on 64bit machines
Closes: #528659
Forwarded: Shaun Purcell <plink@chgr.mgh.harvard.edu>
License: same as plink itself.
===================================================================
--- plink-1.06.orig/Rsrv.h 2009-05-15 03:35:29.000000000 +0100
+++ plink-1.06/Rsrv.h 2009-05-15 03:35:41.000000000 +0100
@@ -313,7 +313,18 @@
#define __BIG_ENDIAN__ 1
#define SWAPEND 1
#elif ! defined Win32 /* Windows is little-endian is most cases, anywhere else we're stuck */
-#error "Cannot determine endianness. Make sure config.h is included or __{BIG|LITTLE}_ENDIAN__ is defined ."
+ //try endian.h before we finally bail out
+ #include <endian.h>
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
+ #warning using little endian based on information from endian.h
+ #define __LITTLE_ENDIAN__ 1
+ #elif __BYTE_ORDER == __BIG_ENDIAN
+ #warning using big endian based on information from endian.h
+ #define __BIG_ENDIAN__ 1
+ #define SWAPEND 1
+ #else
+ #error "Cannot determine endianness. Make sure config.h is included or __{BIG|LITTLE}_ENDIAN__ is defined ."
+ #endif
#endif
/* FIXME: all the mess below needs more efficient implementation - the current one is so messy to work around alignment problems on some platforms like Sun and HP 9000 */