gnu: acl: Fix test regression with perl-5.26.

* gnu/packages/acl.scm (acl)[source]: Add patch.
* gnu/packages/patches/acl-fix-perl-regex.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
Efraim Flashner 2017-11-09 19:47:47 +02:00
parent a864d56302
commit 0f1adf454d
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 26 additions and 1 deletions

View File

@ -520,6 +520,7 @@ dist_patch_DATA = \
%D%/packages/patches/a2ps-CVE-2014-0466.patch \
%D%/packages/patches/abiword-explictly-cast-bools.patch \
%D%/packages/patches/abiword-black-drawing-with-gtk322.patch \
%D%/packages/patches/acl-fix-perl-regex.patch \
%D%/packages/patches/acl-hurd-path-max.patch \
%D%/packages/patches/aegis-constness-error.patch \
%D%/packages/patches/aegis-perl-tempdir1.patch \

View File

@ -2,6 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@ -41,7 +42,8 @@
(sha256
(base32
"08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))
(patches (search-patches "acl-hurd-path-max.patch"))))
(patches (search-patches "acl-fix-perl-regex.patch"
"acl-hurd-path-max.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "tests"

View File

@ -0,0 +1,22 @@
This can be removed with the next acl release
---
test/run | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/run b/test/run
index 2cf52e8..4627cd2 100755
--- a/test/run
+++ b/test/run
@@ -70,7 +70,7 @@ for (;;) {
if (defined $line) {
# Substitute %VAR and %{VAR} with environment variables.
$line =~ s[%(\w+)][$ENV{$1}]eg;
- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
+ $line =~ s[%\{(\w+)\}][$ENV{$1}]eg;
}
if (defined $line) {
if ($line =~ s/^\s*< ?//) {
--
2.15.0