gnu: ruby-concurrent: Update to 1.1.5.

* gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch,
gnu/packages/patches/ruby-concurrent-test-arm.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/ruby.scm (ruby-concurrent): Update to 1.1.5.
[source](patches): Remove.
[arguments]: Set #:test-target to "ci".  Remove obsolete phases.  Remove
dependencies on 'rake_compiler_dock' and concurrent_ruby.jar.
This commit is contained in:
Marius Bakke 2019-10-14 20:52:28 +02:00
parent 8fcba3be28
commit 1007640a63
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
4 changed files with 27 additions and 69 deletions

View File

@ -1302,8 +1302,6 @@ dist_patch_DATA = \
%D%/packages/patches/rtags-separate-rct.patch \
%D%/packages/patches/racket-store-checksum-override.patch \
%D%/packages/patches/ruby-rubygems-276-for-ruby24.patch \
%D%/packages/patches/ruby-concurrent-ignore-broken-test.patch \
%D%/packages/patches/ruby-concurrent-test-arm.patch \
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
%D%/packages/patches/ruby-safe-yaml-add-require-time.patch \
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\

View File

@ -1,16 +0,0 @@
This test appears to fail in GNU Guix and elsewhere. It has been reported
upstream at https://github.com/puma/puma/issues/995
diff --git a/spec/concurrent/channel_spec.rb b/spec/concurrent/channel_spec.rb
index d70fba8..4f29a8b 100644
--- a/spec/concurrent/channel_spec.rb
+++ b/spec/concurrent/channel_spec.rb
@@ -598,7 +598,7 @@ module Concurrent
}.to raise_error(ArgumentError)
end
- it 'loops until the block returns false' do
+ xit 'loops until the block returns false' do
actual = 0
expected = 3
latch = Concurrent::CountDownLatch.new(expected)

View File

@ -1,36 +0,0 @@
Work around two test suite failures on ARM:
https://github.com/ruby-concurrency/concurrent-ruby/issues/547
The regexps here assume addresses like "0x1234" but on ARM (32-bit)
we get something like "0x-7db1e810" (notice the dash).
diff --git a/spec/concurrent/edge/promises_spec.rb b/spec/concurrent/edge/promises_spec.rb
index 727210f..149f7cd 100644
--- a/spec/concurrent/edge/promises_spec.rb
+++ b/spec/concurrent/edge/promises_spec.rb
@@ -371,9 +371,9 @@ describe 'Concurrent::Promises' do
four = three.delay.then(&:succ)
# meaningful to_s and inspect defined for Future and Promise
- expect(head.to_s).to match /<#Concurrent::Promises::Future:0x[\da-f]+ pending>/
+ expect(head.to_s).to match /<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/
expect(head.inspect).to(
- match(/<#Concurrent::Promises::Future:0x[\da-f]+ pending>/))
+ match(/<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/))
# evaluates only up to three, four is left unevaluated
expect(three.value!).to eq 3
diff --git a/spec/concurrent/map_spec.rb b/spec/concurrent/map_spec.rb
index c4050be..0a9095d 100644
--- a/spec/concurrent/map_spec.rb
+++ b/spec/concurrent/map_spec.rb
@@ -794,7 +794,7 @@ module Concurrent
end
it '#inspect' do
- regexp = /\A#<Concurrent::Map:0x[0-9a-f]+ entries=[0-9]+ default_proc=.*>\Z/i
+ regexp = /\A#<Concurrent::Map:0x-?[0-9a-f]+ entries=[0-9]+ default_proc=.*>\Z/i
expect(Concurrent::Map.new.inspect).to match(regexp)
expect((Concurrent::Map.new {}).inspect).to match(regexp)
map = Concurrent::Map.new

View File

@ -6,7 +6,7 @@
;;; Copyright © 2015, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@ -7170,7 +7170,7 @@ call.")
(define-public ruby-concurrent
(package
(name "ruby-concurrent")
(version "1.0.5")
(version "1.1.5")
(source
(origin
(method git-fetch)
@ -7182,14 +7182,10 @@ call.")
(file-name (git-file-name name version))
(sha256
(base32
"1618ald6mhz86hapgw9hs3cvb518k48fk6fxficdrdg3zcx8n302"))
;; Exclude failing test reported at
;; https://github.com/ruby-concurrency/concurrent-ruby/issues/534
(patches (search-patches "ruby-concurrent-ignore-broken-test.patch"
"ruby-concurrent-test-arm.patch"))))
"193q2k47vk7qdvv9hlhmmdxgy91xl4imapyk1ijdg9vgf46knyzj"))))
(build-system ruby-build-system)
(arguments
`(#:test-target "spec"
`(#:test-target "ci"
#:phases
(modify-phases %standard-phases
(add-before 'replace-git-ls-files 'remove-extra-gemspecs
@ -7199,15 +7195,31 @@ call.")
(delete-file "concurrent-ruby-edge.gemspec")
(delete-file "concurrent-ruby-ext.gemspec")
#t))
(add-before 'build 'replace-git-ls-files2
(replace 'replace-git-ls-files
(lambda _
(substitute* "support/file_map.rb"
(("git ls-files") "find * |sort"))
;; XXX: The default substitution made by this phase is not fully
;; compatible with "git ls-files". The latter produces file names
;; such as "lib/foo", whereas ruby-build-system uses "find . [...]"
;; which gives "./lib/foo". That difference in turn breaks the
;; comparison against a glob pattern in this script.
(substitute* "concurrent-ruby.gemspec"
(("git ls-files") "find * -type f | sort"))
#t))
(add-before 'build 'remove-jar-from-gemspec
(lambda _
;; The gemspec wants to include a JAR file that we do not build
;; nor need.
(substitute* "concurrent-ruby.gemspec"
(("'lib/concurrent/concurrent_ruby.jar'")
""))
#t))
(add-before 'build 'remove-rake_compiler_dock-dependency
(lambda _
;; This library is only used when building for non-MRI targets.
(substitute* "Rakefile"
(("require 'rake_compiler_dock'")
""))
#t))
(add-before 'check 'rake-compile
;; Fix the test error described at
;; https://github.com/ruby-concurrency/concurrent-ruby/pull/408
(lambda _ (invoke "rake" "compile")))
(add-before 'check 'remove-timecop-dependency
;; Remove timecop-dependent tests as having timecop as a depedency
;; causes circular depedencies.