gnu: containerd: Fix test failure with Go 1.13.

* gnu/packages/docker.scm (containerd)[source]: Add patch.
* gnu/packages/patches/containerd-test-with-go1.13.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add patch.
This commit is contained in:
Jack Hill 2020-02-12 15:33:43 -05:00 committed by Danny Milosavljevic
parent 7d9f8db2a8
commit 13c8e747e8
No known key found for this signature in database
GPG Key ID: E71A35542C30BAA5
3 changed files with 25 additions and 1 deletions

View File

@ -794,6 +794,7 @@ dist_patch_DATA = \
%D%/packages/patches/coda-use-system-libs.patch \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
%D%/packages/patches/containerd-test-with-go1.13.patch \
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/crawl-upgrade-saves.patch \
%D%/packages/patches/crda-optional-gcrypt.patch \

View File

@ -183,7 +183,9 @@ Python without keeping their credentials in a Docker configuration file.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0npbzixf3c0jvzm159vygvkydrr8h36c9sq50yv0mdinrys2bvg0"))))
(base32 "0npbzixf3c0jvzm159vygvkydrr8h36c9sq50yv0mdinrys2bvg0"))
(patches
(search-patches "containerd-test-with-go1.13.patch"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/containerd/containerd"

View File

@ -0,0 +1,21 @@
Compatibility fix for go 1.13, flag.Parse() shouldn't be called during
package initialization.
https://golang.org/doc/go1.13#testing
--- a/client_test.go 2020-02-12 14:50:28.991245371 -0500
+++ b/client_test.go 2020-02-12 15:12:37.383523980 -0500
@@ -49,7 +49,6 @@
flag.StringVar(&address, "address", defaultAddress, "The address to the containerd socket for use in the tests")
flag.BoolVar(&noDaemon, "no-daemon", false, "Do not start a dedicated daemon for the tests")
flag.BoolVar(&noCriu, "no-criu", false, "Do not run the checkpoint tests")
- flag.Parse()
}
func testContext() (context.Context, context.CancelFunc) {
@@ -59,6 +58,7 @@
}
func TestMain(m *testing.M) {
+ flag.Parse()
if testing.Short() {
os.Exit(m.Run())
}