gnu: flint: Update to 2.6.0.

* gnu/packages/algebra.scm (flint): Update to 2.6.0.
* gnu/packages/patches/flint-ldconfig.patch: Remove the patch as it got
  applied upstream.
* gnu/local.mk (dist_patch_DATA): Deregister the removed file.
This commit is contained in:
Jakub Kądziołka 2020-06-08 01:51:52 +02:00
parent cc7b170db2
commit 16e34f7598
No known key found for this signature in database
GPG Key ID: E315A75846131564
3 changed files with 2 additions and 30 deletions

View File

@ -937,7 +937,6 @@ dist_patch_DATA = \
%D%/packages/patches/findutils-localstatedir.patch \
%D%/packages/patches/findutils-test-rwlock-threads.patch \
%D%/packages/patches/flann-cmake-3.11.patch \
%D%/packages/patches/flint-ldconfig.patch \
%D%/packages/patches/foobillard++-pkg-config.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \

View File

@ -440,15 +440,14 @@ or text interfaces) or as a C++ library.")
(define-public flint
(package
(name "flint")
(version "2.5.2")
(version "2.6.0")
(source (origin
(method url-fetch)
(uri (string-append
"http://flintlib.org/flint-"
version ".tar.gz"))
(sha256 (base32
"11syazv1a8rrnac3wj3hnyhhflpqcmq02q8pqk2m6g2k6h0gxwfb"))
(patches (search-patches "flint-ldconfig.patch"))))
"0h08a71kn8347zsqjamqnmrxjpsnnzpmhvxb6d2xmfrcs6nyv2ch"))))
(build-system gnu-build-system)
(propagated-inputs
`(("gmp" ,gmp)

View File

@ -1,26 +0,0 @@
Patch by Andreas Enge <andreas@enge.fr>.
Remedy the absence of ldconfig and explicitly create an additional symbolic
link to the flint library, as discussed privately with upstream.
diff -r -u flint-2.5.2.orig/configure flint-2.5.2/configure
--- flint-2.5.2.orig/configure 2015-08-13 18:16:22.000000000 +0200
+++ flint-2.5.2/configure 2015-08-14 17:38:14.316284437 +0200
@@ -714,6 +714,7 @@
echo "FLINT_SHARED=$SHARED" >> Makefile
echo "FLINT_LIB=$FLINT_LIB" >> Makefile
echo "FLINT_LIBNAME=$FLINT_LIBNAME" >> Makefile
+echo "FLINT_MAJOR=$FLINT_MAJOR" >> Makefile
echo "FLINT_SOLIB=$FLINT_SOLIB" >> Makefile
echo "EXEEXT=$EXEEXT" >> Makefile
echo "PREFIX=$PREFIX" >> Makefile
diff -r -u flint-2.5.2.orig/Makefile.in flint-2.5.2/Makefile.in
--- flint-2.5.2.orig/Makefile.in 2015-08-13 18:16:22.000000000 +0200
+++ flint-2.5.2/Makefile.in 2015-08-14 17:38:50.584774817 +0200
@@ -118,6 +118,7 @@
$(LDCONFIG) -n "$(CURDIR)"; \
fi
ln -sf "$(FLINT_LIB)" "$(FLINT_LIBNAME)"; \
+ ln -sf "$(FLINT_LIB)" "$(FLINT_LIBNAME).$(FLINT_MAJOR)"; \
libflint.a: $(OBJS) $(LIB_SOURCES) $(EXT_SOURCES) $(HEADERS) $(EXT_HEADERS) | build build/interfaces
$(AT)$(foreach ext, $(EXTENSIONS), $(foreach dir, $(filter-out %templates, $(patsubst $(ext)/%.h, %, $(wildcard $(ext)/*.h))), mkdir -p build/$(dir); BUILD_DIR=$(CURDIR)/build/$(dir); export BUILD_DIR; MOD_DIR=$(dir); export MOD_DIR; $(MAKE) -f $(CURDIR)/Makefile.subdirs -C $(ext)/$(dir) static || exit $$?;))