gnu: elixir: Update to 1.8.1.

* gnu/packages/elixir.scm (elixir): Update to 1.8.1.
[source](patches): New field.
[home-page]: Use HTTPS.
* gnu/packages/patches/elixir-path-length.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
This commit is contained in:
Robert Smith 2019-03-18 15:05:18 +01:00 committed by Marius Bakke
parent 7ac8d96d77
commit 2f87048dbe
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 20 additions and 3 deletions

View File

@ -732,6 +732,7 @@ dist_patch_DATA = \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
%D%/packages/patches/efl-mesa-compat.patch \
%D%/packages/patches/elfutils-tests-ptrace.patch \
%D%/packages/patches/elixir-path-length.patch \
%D%/packages/patches/einstein-build.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \

View File

@ -33,7 +33,7 @@
(define-public elixir
(package
(name "elixir")
(version "1.6.6")
(version "1.8.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/elixir-lang/elixir"
@ -41,7 +41,8 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0c9qz5hasa59a9x1iwpcqpqj6wdbzpijfxqfmzimwj5z8q37nl3l"))))
"08lq5p82pnicd49gsj6r2zsbg35wrk6098nrrjb28fcrm5p6736y"))
(patches (search-patches "elixir-path-length.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@ -84,7 +85,7 @@
(inputs
`(("erlang" ,erlang)
("git" ,git)))
(home-page "http://elixir-lang.org/")
(home-page "https://elixir-lang.org/")
(synopsis "Elixir programming language")
(description "Elixir is a dynamic, functional language used to build
scalable and maintainable applications. Elixir leverages the Erlang VM, known

View File

@ -0,0 +1,15 @@
In the package definition the call to the command 'git' is substituted with
the full path to the git executable. This change causes the mix formatting tool
to complain that the line is too long. This workaround reformats the file
after the substitution is made.
--- a/Makefile
+++ b/Makefile
@@ -213,6 +213,7 @@
TEST_ERLS = $(addprefix $(TEST_EBIN)/, $(addsuffix .beam, $(basename $(notdir $(wildcard $(TEST_ERL)/*.erl)))))
test_formatted: compile
+ bin/elixir bin/mix format lib/mix/lib/mix/scm/git.ex
bin/elixir bin/mix format --check-formatted
test_erlang: compile $(TEST_ERLS)