gnu: dconf: Fix build failure with Meson 0.52.

* gnu/packages/patches/dconf-meson-0.52.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/gnome.scm (dconf)[source](patches): New field.
This commit is contained in:
Marius Bakke 2019-12-06 18:20:51 +01:00
parent eb5f3ea100
commit 46c3a08b2e
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 21 additions and 0 deletions

View File

@ -798,6 +798,7 @@ dist_patch_DATA = \
%D%/packages/patches/dbus-helper-search-path.patch \
%D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \
%D%/packages/patches/dconf-meson-0.52.patch \
%D%/packages/patches/debops-constants-for-external-program-names.patch \
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \

View File

@ -2851,6 +2851,7 @@ and RDP protocols.")
"mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(patches (search-patches "dconf-meson-0.52.patch"))
(sha256
(base32
"1azz4hb9z76yxn34yrrsiib3iqz5z4vpwn5q7cncp55w365ygg38"))))

View File

@ -0,0 +1,19 @@
Fix build failure with Meson 0.52.
Taken from upstream:
https://gitlab.gnome.org/GNOME/dconf/commit/7ad890fb7a2ec90a777a756a1fa20a615ec7245e
https://gitlab.gnome.org/GNOME/dconf/merge_requests/54
diff --git a/client/meson.build b/client/meson.build
index f3b7122cb05bfa7bb481c487e3cd052aa1ad58e5..de6387e2cac2aba12b83f2614c277bada434fd16 100644
--- a/client/meson.build
+++ b/client/meson.build
@@ -28,7 +28,7 @@ libdconf_client = static_library(
libdconf_client_dep = declare_dependency(
dependencies: gio_dep,
- link_whole: libdconf_client,
+ link_with: libdconf_client,
)
libdconf = shared_library(