gnu: Add emacs-wordnut.

* gnu/packages/patches/emacs-wordnut-require-adaptive-wrap.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add previous file.
* gnu/packages/emacs.scm (emacs-wordnut): New package.
This commit is contained in:
Mathieu Othacehe 2018-12-18 21:24:16 +09:00
parent 39c676c4a3
commit 4b33a74138
No known key found for this signature in database
GPG Key ID: 8354763531769CA6
3 changed files with 47 additions and 0 deletions

View File

@ -674,6 +674,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-realgud-fix-configure-ac.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/erlang-man-path.patch \
%D%/packages/patches/eudev-rules-directory.patch \

View File

@ -12828,3 +12828,29 @@ testing Emacs Lisp code. It allows to group related tests so they can share
common set-up and tear-down code, and allows the programmer to \"spy\" on
functions to ensure they are called with the right arguments during testing.")
(license license:gpl3+)))
(define-public emacs-wordnut
(let ((commit "feac531404041855312c1a046bde7ea18c674915")
(revision "0"))
(package
(name "emacs-wordnut")
(version (git-version "0.1" revision commit))
(home-page "https://github.com/gromnitsky/wordnut")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page) (commit commit)))
(sha256
(base32
"1jl0b6g64a9w0q7bfvwha67vgws5xd15b7mkfyb5gkz3pymqhfxn"))
(patches
(search-patches "emacs-wordnut-require-adaptive-wrap.patch"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(propagated-inputs
`(("wordnet" ,wordnet)
("emacs-adaptive-wrap" ,emacs-adaptive-wrap)))
(synopsis "Major mode for WordNet")
(description "This Emacs package provides an interface for
@code{wordnet}. Features include completion, if the query is not found
too ambiguous and navigation in the result buffer.")
(license license:gpl3+))))

View File

@ -0,0 +1,20 @@
Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
This patch forces the use of adaptive-wrap. This feature is optional but we
prefer to enable it by default.
diff --git a/wordnut.el b/wordnut.el
index 0ae86ad..72f9221 100644
--- a/wordnut.el
+++ b/wordnut.el
@@ -4,6 +4,7 @@
(require 'subr-x)
(require 'outline)
(require 'imenu)
+(require 'adaptive-wrap)
(require 'wordnut-history)
--
2.17.1