gnu: glibc: Add clock patches for the Hurd.

* gnu/packages/patches/glibc-hurd-clock_t_centiseconds.patch: New file.
* gnu/packages/patches/glibc-hurd-clock_gettime_monotonic.patch: New file.
* gnu/local.mk (dist_patch_DATA): Update them.
* gnu/packages/base.scm (glibc): Use them.
This commit is contained in:
Jan Nieuwenhuizen 2020-03-01 16:37:37 +01:00
parent 9b943db357
commit 974c42a70a
No known key found for this signature in database
GPG Key ID: F3C1A0D9C1D65273
4 changed files with 180 additions and 2 deletions

View File

@ -11,7 +11,7 @@
# Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
# Copyright © 2016, 2017, 2018, 2019 Alex Vong <alexvong1995@gmail.com>
# Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
# Copyright © 2016, 2017, 2018, 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
# Copyright © 2016, 2017, 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
# Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
# Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
# Copyright © 2017, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
@ -962,6 +962,8 @@ dist_patch_DATA = \
%D%/packages/patches/glibc-bootstrap-system-2.16.0.patch \
%D%/packages/patches/glibc-bootstrap-system.patch \
%D%/packages/patches/glibc-hidden-visibility-ldconfig.patch \
%D%/packages/patches/glibc-hurd-clock_gettime_monotonic.patch \
%D%/packages/patches/glibc-hurd-clock_t_centiseconds.patch \
%D%/packages/patches/glibc-hurd-magic-pid.patch \
%D%/packages/patches/glibc-ldd-x86_64.patch \
%D%/packages/patches/glibc-locales.patch \

View File

@ -612,7 +612,9 @@ the store.")
"glibc-versioned-locpath.patch"
"glibc-allow-kernel-2.6.32.patch"
"glibc-reinstate-prlimit64-fallback.patch"
"glibc-supported-locales.patch"))))
"glibc-supported-locales.patch"
"glibc-hurd-clock_t_centiseconds.patch"
"glibc-hurd-clock_gettime_monotonic.patch"))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc

View File

@ -0,0 +1,84 @@
This is needed to run Python on the Hurd, especially during the build of
python-boot0.
Adapted from https://salsa.debian.org/glibc-team/glibc/-/blob/glibc-2.31/debian/patches/hurd-i386/unsubmitted-clock_t_centiseconds.diff
Use the realtime clock for the monotonic clock. This is of course not a proper
implementation (which is being done in Mach), but will permit to fix at least
the iceweasel stack.
vlc however doesn't build when _POSIX_CLOCK_SELECTION is enabled but
_POSIX_TIMERS is not, and they refuse to fix that (see #765578), so disable the
former.
From 0aa1dfd580cf9ad7b812c307b128decb782b825f Mon Sep 17 00:00:00 2001
From: Jan Nieuwenhuizen <janneke@gnu.org>
Date: Mon, 2 Mar 2020 18:59:04 +0100
Subject: [PATCH 2/2] Use realtime clock for the monotonic clock.
---
sysdeps/mach/clock_gettime.c | 2 +-
sysdeps/mach/hurd/bits/posix_opt.h | 6 +++---
sysdeps/posix/clock_getres.c | 1 +
sysdeps/pthread/timer_create.c | 2 +-
4 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/sysdeps/mach/clock_gettime.c b/sysdeps/mach/clock_gettime.c
index ac3547df3c..af8681ba4e 100644
--- a/sysdeps/mach/clock_gettime.c
+++ b/sysdeps/mach/clock_gettime.c
@@ -25,7 +25,7 @@
int
__clock_gettime (clockid_t clock_id, struct timespec *ts)
{
- if (clock_id != CLOCK_REALTIME)
+ if (clock_id != CLOCK_MONOTONIC && clock_id != CLOCK_REALTIME)
{
errno = EINVAL;
return -1;
diff --git a/sysdeps/mach/hurd/bits/posix_opt.h b/sysdeps/mach/hurd/bits/posix_opt.h
index 0050151332..27b3a28ab7 100644
--- a/sysdeps/mach/hurd/bits/posix_opt.h
+++ b/sysdeps/mach/hurd/bits/posix_opt.h
@@ -163,10 +163,10 @@
#define _POSIX_THREAD_PROCESS_SHARED -1
/* The monotonic clock might be available. */
-#define _POSIX_MONOTONIC_CLOCK 0
+#define _POSIX_MONOTONIC_CLOCK 200809L
-/* The clock selection interfaces are available. */
-#define _POSIX_CLOCK_SELECTION 200809L
+/* The clock selection interfaces are not really available yet. */
+#define _POSIX_CLOCK_SELECTION -1
/* Advisory information interfaces could be available in future. */
#define _POSIX_ADVISORY_INFO 0
diff --git a/sysdeps/posix/clock_getres.c b/sysdeps/posix/clock_getres.c
index fcd79fd554..1dd02aa449 100644
--- a/sysdeps/posix/clock_getres.c
+++ b/sysdeps/posix/clock_getres.c
@@ -52,6 +52,7 @@ __clock_getres (clockid_t clock_id, struct timespec *res)
switch (clock_id)
{
case CLOCK_REALTIME:
+ case CLOCK_MONOTONIC:
retval = realtime_getres (res);
break;
diff --git a/sysdeps/pthread/timer_create.c b/sysdeps/pthread/timer_create.c
index 9d8a9ea8ae..3430582c09 100644
--- a/sysdeps/pthread/timer_create.c
+++ b/sysdeps/pthread/timer_create.c
@@ -48,7 +48,7 @@ timer_create (clockid_t clock_id, struct sigevent *evp, timer_t *timerid)
return -1;
}
- if (clock_id != CLOCK_REALTIME)
+ if (clock_id != CLOCK_REALTIME && clock_id != CLOCK_MONOTONIC)
{
__set_errno (EINVAL);
return -1;
--
2.24.0

View File

@ -0,0 +1,90 @@
This is needed to run Python on the Hurd, especially during the build of
python-boot0.
Adapted from https://salsa.debian.org/glibc-team/glibc/-/blob/glibc-2.31/debian/patches/hurd-i386/unsubmitted-clock_t_centiseconds.diff
commit d57f2f9b4bd007846af2fb4217486ea572579010
Author: Richard Braun <rbraun@sceen.net>
Date: Tue Aug 27 11:35:31 2013 +0200
Express CPU time (clock_t of times(2)) in centiseconds
From 170c292b643fdc1eb56881e6592b07c0c019993e Mon Sep 17 00:00:00 2001
From: Jan Nieuwenhuizen <janneke@gnu.org>
Date: Mon, 2 Mar 2020 18:28:54 +0100
Subject: [PATCH 1/2] Express CPU time (clock_t) in centiseconds
---
sysdeps/mach/hurd/clock.c | 8 ++++----
sysdeps/mach/hurd/getclktck.c | 5 ++---
sysdeps/mach/hurd/setitimer.c | 2 +-
sysdeps/mach/hurd/times.c | 2 +-
4 files changed, 8 insertions(+), 9 deletions(-)
diff --git a/sysdeps/mach/hurd/clock.c b/sysdeps/mach/hurd/clock.c
index 7cb42df786..4db49b579d 100644
--- a/sysdeps/mach/hurd/clock.c
+++ b/sysdeps/mach/hurd/clock.c
@@ -44,10 +44,10 @@ clock (void)
if (err)
return __hurd_fail (err);
- total = bi.user_time.seconds * 1000000 + bi.user_time.microseconds;
- total += tti.user_time.seconds * 1000000 + tti.user_time.microseconds;
- total += bi.system_time.seconds * 1000000 + bi.system_time.microseconds;
- total += tti.system_time.seconds * 1000000 + tti.system_time.microseconds;
+ total = bi.user_time.seconds * 100 + bi.user_time.microseconds / 10000;
+ total += tti.user_time.seconds * 100 + tti.user_time.microseconds / 10000;
+ total += bi.system_time.seconds * 100 + bi.system_time.microseconds / 10000;
+ total += tti.system_time.seconds * 100 + tti.system_time.microseconds / 10000;
return total;
}
diff --git a/sysdeps/mach/hurd/getclktck.c b/sysdeps/mach/hurd/getclktck.c
index 943e36e805..5a3cf0930b 100644
--- a/sysdeps/mach/hurd/getclktck.c
+++ b/sysdeps/mach/hurd/getclktck.c
@@ -18,12 +18,11 @@
#include <time.h>
-/* Return frequency of `times'.
- Since Mach reports CPU times in microseconds, we always use 1 million. */
+/* Return frequency of `times'. */
int
__getclktck (void)
{
- return 1000000;
+ return 100;
}
/* Before glibc 2.2, the Hurd actually did this differently, so we
diff --git a/sysdeps/mach/hurd/setitimer.c b/sysdeps/mach/hurd/setitimer.c
index b16f4ddd5d..8bf1464830 100644
--- a/sysdeps/mach/hurd/setitimer.c
+++ b/sysdeps/mach/hurd/setitimer.c
@@ -43,7 +43,7 @@ quantize_timeval (struct timeval *tv)
static time_t quantum = -1;
if (quantum == -1)
- quantum = 1000000 / __getclktck ();
+ quantum = 100 / __getclktck ();
tv->tv_usec = ((tv->tv_usec + (quantum - 1)) / quantum) * quantum;
if (tv->tv_usec >= 1000000)
diff --git a/sysdeps/mach/hurd/times.c b/sysdeps/mach/hurd/times.c
index 23ed992783..cbf6039b19 100644
--- a/sysdeps/mach/hurd/times.c
+++ b/sysdeps/mach/hurd/times.c
@@ -29,7 +29,7 @@
static inline clock_t
clock_from_time_value (const time_value_t *t)
{
- return t->seconds * 1000000 + t->microseconds;
+ return t->seconds * 100 + t->microseconds / 10000;
}
/* Store the CPU time used by this process and all its
--
2.24.0