gnu: icecat: Include generally-useful fixes in the source tarball.

This commit moves some important fixes into a patch applied to the upstream
gnuzilla git repository, whereas previously they were applied in such a way
that only benefitted Guix users.

* gnu/packages/patches/icecat-default-search-ddg.patch,
gnu/packages/patches/icecat-disable-sync.patch: Delete files.
* gnu/packages/patches/icecat-gnuzilla-fixes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adapt accordingly.
* gnu/packages/gnuzilla.scm (icecat-source): Apply the new patch to the
gnuzilla checkout.
(icecat)[native-inputs]: Remove deleted patches.
[arguments]: In the 'wrap-program' phase, remove MOZ_LEGACY_PROFILES=1
from the wrapper.
This commit is contained in:
Mark H Weaver 2019-10-26 22:17:05 -04:00
parent ce23c5ffd2
commit a06193603b
No known key found for this signature in database
GPG Key ID: 7CEF29847562C516
6 changed files with 1172 additions and 1127 deletions

View File

@ -975,9 +975,8 @@ dist_patch_DATA = \
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
%D%/packages/patches/hplip-remove-imageprocessor.patch \
%D%/packages/patches/hydra-disable-darcs-test.patch \
%D%/packages/patches/icecat-gnuzilla-fixes.patch \
%D%/packages/patches/icecat-makeicecat.patch \
%D%/packages/patches/icecat-default-search-ddg.patch \
%D%/packages/patches/icecat-disable-sync.patch \
%D%/packages/patches/icecat-avoid-bundled-libraries.patch \
%D%/packages/patches/icecat-use-system-graphite2+harfbuzz.patch \
%D%/packages/patches/icecat-use-system-media-libs.patch \

View File

@ -588,6 +588,8 @@ from forcing GEXP-PROMISE."
(base32
"1ll3j2kpsfp1f9dxy67fay1cidsng02l8a3a23wdjqkxgrg1cf4g"))))
(gnuzilla-fixes-patch
(local-file (search-patch "icecat-gnuzilla-fixes.patch")))
(makeicecat-patch
(local-file (search-patch "icecat-makeicecat.patch"))))
@ -633,6 +635,8 @@ from forcing GEXP-PROMISE."
(with-directory-excursion "/tmp/gnuzilla"
(make-file-writable "makeicecat")
(invoke "patch" "--force" "--no-backup-if-mismatch"
"-p1" "--input" #+gnuzilla-fixes-patch)
(invoke "patch" "--force" "--no-backup-if-mismatch"
"-p1" "--input" #+makeicecat-patch)
(patch-shebang "makeicecat")
@ -772,10 +776,6 @@ from forcing GEXP-PROMISE."
;; ,(search-patch "icecat-use-system-graphite2+harfbuzz.patch"))
;; ("icecat-use-system-media-libs.patch"
;; ,(search-patch "icecat-use-system-media-libs.patch"))
("icecat-default-search-ddg.patch"
,(search-patch "icecat-default-search-ddg.patch"))
("icecat-disable-sync.patch"
,(search-patch "icecat-disable-sync.patch"))
("patch" ,(canonical-package patch))
@ -1079,8 +1079,7 @@ from forcing GEXP-PROMISE."
(pulseaudio-lib (string-append pulseaudio "/lib")))
(wrap-program (car (find-files lib "^icecat$"))
`("XDG_DATA_DIRS" prefix (,gtk-share))
`("LD_LIBRARY_PATH" prefix (,pulseaudio-lib))
`("MOZ_LEGACY_PROFILES" = ("1")))
`("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
#t))))))
(home-page "https://www.gnu.org/software/gnuzilla/")
(synopsis "Entirely free browser derived from Mozilla Firefox")

File diff suppressed because it is too large Load Diff

View File

@ -1,9 +0,0 @@
--- a/browser/app/profile/icecat.js.orig 1980-01-01 18:59:51.000000000 -0500
+++ b/browser/app/profile/icecat.js 2019-10-25 06:24:03.065989309 -0400
@@ -2275,3 +2275,6 @@
pref("general.buildID.override", "Gecko/20100101");
pref("general.oscpu.override", "Windows NT 6.1");
pref("general.platform.override", "Win32");
+
+// Disable Firefox Accounts and Sign in to Sync.
+pref("identity.fxaccounts.enabled", false);

File diff suppressed because it is too large Load Diff

View File

@ -96,8 +96,8 @@ index b04c731..06d1f3f 100644
-cd $SOURCEDIR
+# cd $SOURCEDIR
#for patch in $DATA/patches/*; do
# echo Patching with file: $patch
for patch in $DATA/patches/*.patch; do
echo Patching with file: $patch
@@ -226,10 +226,10 @@ cp $DATA/bookmarks.html.in browser/locales/generic/profile/bookmarks.html.in
find -wholename '*/brand.dtd' |xargs /bin/sed 's/trademarkInfo.part1.*/trademarkInfo.part1 "">/' -i