gnu: perl-www-curl: Fix build failure.

* gnu/packages/patches/perl-www-curl-remove-symbol.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/web.scm (perl-www-curl)[source]: Use it.
This commit is contained in:
Leo Famulari 2016-10-24 18:37:02 -04:00
parent c4a667bfa5
commit a19da40630
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 41 additions and 0 deletions

View File

@ -751,6 +751,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-no-sys-dirs.patch \
%D%/packages/patches/perl-module-pluggable-search.patch \
%D%/packages/patches/perl-reproducible-build-date.patch \
%D%/packages/patches/perl-www-curl-remove-symbol.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pinball-const-fix.patch \
%D%/packages/patches/pinball-cstddef.patch \

View File

@ -0,0 +1,39 @@
Fix build failure caused by erroneous use of an undeclared symbol.
Patch copied from upstream bug report:
https://rt.cpan.org/Public/Bug/Display.html?id=117793
From 0be0223422e6e5f4091c6e4e058d213623eed105 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 12 Sep 2016 14:40:44 +0200
Subject: [PATCH] Skip preprocessor symbol only CURL_STRICTER
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
CURL_STRICTER leaked into curl-constants.c when building against
curl-7.50.2. This is a preprocessor only macro without a value.
CPAN RT#117793
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.PL b/Makefile.PL
index f9170bb..ad2bd3d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
close H;
for my $e (sort @syms) {
- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
+ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|_LAST\z|_LASTENTRY\z)/) {
next;
}
my ($group) = $e =~ m/^([^_]+_)/;
--
2.7.4

View File

@ -3053,6 +3053,7 @@ RFC 6570.")
(uri (string-append
"mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
version".tar.gz"))
(patches (search-patches "perl-www-curl-remove-symbol.patch"))
(sha256
(base32
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))