gnu: Add gcc@8.

* gnu/packages/patches/gcc-8-strmov-store-file-names.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/gcc.scm (gcc-8): New public variable.
This commit is contained in:
Marius Bakke 2018-06-26 01:52:18 +02:00
parent 683016907d
commit a1fa2691cd
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 126 additions and 0 deletions

View File

@ -707,6 +707,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
%D%/packages/patches/gcc-6-source-date-epoch-1.patch \
%D%/packages/patches/gcc-6-source-date-epoch-2.patch \
%D%/packages/patches/gcc-8-strmov-store-file-names.patch \
%D%/packages/patches/gcr-disable-failing-tests.patch \
%D%/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch \
%D%/packages/patches/gd-CVE-2018-5711.patch \

View File

@ -6,6 +6,7 @@
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@ -515,6 +516,20 @@ Go. It also includes runtime support libraries for these languages.")
for several languages, including C, C++, Objective-C, Fortran, Ada, and Go.
It also includes runtime support libraries for these languages.")))
(define-public gcc-8
(package
(inherit gcc-7)
(version "8.1.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gcc/gcc-"
version "/gcc-" version ".tar.xz"))
(sha256
(base32
"0lxil8x0jjx7zbf90cy1rli650akaa6hpk8wk8s62vk2jbwnc60x"))
(patches (search-patches "gcc-8-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"))))))
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions and the gfortran definition
;; accordingly.

View File

@ -0,0 +1,110 @@
Make sure that statements such as:
strcpy (dst, "/gnu/store/…");
or
static const char str[] = "/gnu/store/…";
strcpy (dst, str);
do not result in chunked /gnu/store strings that are undetectable by
Guix's GC and its grafting code. See <https://bugs.gnu.org/24703>
and <https://bugs.gnu.org/30395>.
--- gcc-5.3.0/gcc/builtins.c 2016-10-18 10:50:46.080616285 +0200
+++ gcc-5.3.0/gcc/builtins.c 2016-11-09 15:26:43.693042737 +0100
@@ -3012,6 +3012,58 @@ determine_block_size (tree len, rtx len_rtx,
GET_MODE_MASK (GET_MODE (len_rtx)));
}
+extern void debug_tree (tree);
+
+/* Return true if STR contains the string "/gnu/store". */
+
+bool
+store_reference_p (tree str)
+{
+ if (getenv ("GUIX_GCC_DEBUG") != NULL)
+ debug_tree (str);
+
+ if (TREE_CODE (str) == ADDR_EXPR)
+ str = TREE_OPERAND (str, 0);
+
+ if (TREE_CODE (str) == VAR_DECL
+ && TREE_STATIC (str)
+ && TREE_READONLY (str))
+ {
+ /* STR may be a 'static const' variable whose initial value
+ is a string constant. See <https://bugs.gnu.org/30395>. */
+ str = DECL_INITIAL (str);
+ if (str == NULL_TREE)
+ return false;
+ }
+
+ if (TREE_CODE (str) != STRING_CST)
+ return false;
+
+ int len;
+ const char *store;
+
+ store = getenv ("NIX_STORE") ? getenv ("NIX_STORE") : "/gnu/store";
+ len = strlen (store);
+
+ /* Size of the hash part of store file names, including leading slash and
+ trailing hyphen. */
+ const int hash_len = 34;
+
+ if (TREE_STRING_LENGTH (str) < len + hash_len)
+ return false;
+
+ /* We cannot use 'strstr' because 'TREE_STRING_POINTER' returns a string
+ that is not necessarily NUL-terminated. */
+
+ for (int i = 0; i < TREE_STRING_LENGTH (str) - (len + hash_len); i++)
+ {
+ if (strncmp (TREE_STRING_POINTER (str) + i, store, len) == 0)
+ return true;
+ }
+
+ return false;
+}
+
/* Try to verify that the sizes and lengths of the arguments to a string
manipulation function given by EXP are within valid bounds and that
the operation does not lead to buffer overflow or read past the end.
@@ -3605,6 +3657,13 @@ expand_builtin_memory_copy_args (tree dest, tree src, tree len,
unsigned HOST_WIDE_INT max_size;
unsigned HOST_WIDE_INT probable_max_size;
+ /* Do not emit block moves, which translate to the 'movabs' instruction on
+ x86_64, when SRC refers to store items. That way, store references
+ remain visible to the Guix GC and grafting code. See
+ <https://bugs.gnu.org/24703>. */
+ if (store_reference_p (src))
+ return NULL_RTX;
+
/* If DEST is not a pointer type, call the normal function. */
if (dest_align == 0)
return NULL_RTX;
--- gcc-5.5.0/gcc/gimple-fold.c 2018-03-20 11:36:16.709442004 +0100
+++ gcc-5.5.0/gcc/gimple-fold.c 2018-03-20 11:46:43.838487065 +0100
@@ -635,6 +635,8 @@ var_decl_component_p (tree var)
return SSA_VAR_P (inner);
}
+extern bool store_reference_p (tree);
+
/* If the SIZE argument representing the size of an object is in a range
of values of which exactly one is valid (and that is zero), return
true, otherwise false. */
@@ -742,6 +744,9 @@ gimple_fold_builtin_memory_op (gimple_stmt_iterator *gsi,
off0 = build_int_cst (build_pointer_type_for_mode (char_type_node,
ptr_mode, true), 0);
+ if (store_reference_p (src))
+ return false;
+
/* If we can perform the copy efficiently with first doing all loads
and then all stores inline it that way. Currently efficiently
means that we can load all the memory into a single integer