gnu: opendht: Add patch.

The 2.1.4 release of opendht contains a bug, preventing it's use with recent
releases of Jami.  This minor patch [1] resolves this issue, and should be
possible to remove with the next release.

1: e2b39dd3a0

* gnu/packages/patches/opendht-fix-jami.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/networking.scm (opendht)[source]: Apply the patch.

Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
Jan Wielkiewicz 2020-07-12 18:00:47 +02:00 committed by Christopher Baines
parent 8551bc64e4
commit bc6239ba07
No known key found for this signature in database
GPG Key ID: 5E28A33B0B84F577
3 changed files with 35 additions and 0 deletions

View File

@ -1344,6 +1344,7 @@ dist_patch_DATA = \
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
%D%/packages/patches/opencv-rgbd-aarch64-test-fix.patch \
%D%/packages/patches/opendht-fix-jami.patch \
%D%/packages/patches/openfoam-4.1-cleanup.patch \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
%D%/packages/patches/openmpi-mtl-priorities.patch \

View File

@ -2918,6 +2918,7 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(url "https://github.com/savoirfairelinux/opendht.git")
(commit version)))
(file-name (git-file-name name version))
(patches (search-patches "opendht-fix-jami.patch"))
(sha256
(base32
"1ax26ri1ifb6s8ppd28jmanka9yf8mw3np65q2h4djhhik0phhal"))))

View File

@ -0,0 +1,33 @@
From e2b39dd3a0742853e00f9c3e8c46c911da20bed7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Adrien=20B=C3=A9raud?= <adrien.beraud@savoirfairelinux.com>
Date: Tue, 30 Jun 2020 10:42:49 -0400
Subject: [PATCH 1/4] http/request: make terminate public
---
include/opendht/http.h | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/include/opendht/http.h b/include/opendht/http.h
index cc8d5f9..46b722c 100644
--- a/include/opendht/http.h
+++ b/include/opendht/http.h
@@ -294,6 +294,7 @@ public:
* User action to cancel the Request and call the completion callbacks.
*/
void cancel();
+ void terminate(const asio::error_code& ec);
private:
using OnCompleteCb = std::function<void()>;
@@ -320,8 +321,6 @@ private:
void connect(std::vector<asio::ip::tcp::endpoint>&& endpoints, HandlerCb cb = {});
- void terminate(const asio::error_code& ec);
-
void post();
void handle_request(const asio::error_code& ec);
--
2.27.0