gnu: choqok: Update to 1.7.0.

* gnu/packages/kde-internet.scm (choqok): Update to 1.7.0.
  (inputs): Add purpose, qtnetworkauth.
  (source): Don't apply patch.
* gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch: Remove
  (no longer needed).
This commit is contained in:
Jakub Kądziołka 2020-02-22 00:09:52 +01:00
parent 76a8dc3ee2
commit c080beb9c7
No known key found for this signature in database
GPG Key ID: E315A75846131564
3 changed files with 4 additions and 93 deletions

View File

@ -774,7 +774,6 @@ dist_patch_DATA = \
%D%/packages/patches/ceph-disable-cpu-optimizations.patch \
%D%/packages/patches/ceph-volume-respect-PATH.patch \
%D%/packages/patches/chmlib-inttypes.patch \
%D%/packages/patches/choqok-Fix-building-under-Qt-5.13.patch \
%D%/packages/patches/clamav-config-llvm-libs.patch \
%D%/packages/patches/clamav-system-tomsfastmath.patch \
%D%/packages/patches/clang-3.5-libc-search-path.patch \

View File

@ -51,7 +51,7 @@
(define-public choqok
(package
(name "choqok")
(version "1.6.0")
(version "1.7.0")
(source
(origin
(method url-fetch)
@ -59,8 +59,7 @@
(version-major+minor version)
"/src/choqok-" version ".tar.xz"))
(sha256
(base32 "03ri4y1wzyqlixnhczsls5gmy7jzzm67bb5gz8bav51ngc32fxca"))
(patches (search-patches "choqok-Fix-building-under-Qt-5.13.patch"))))
(base32 "0zm4nkpmvd181xlkis7ydzx54p3vn0zgpdzgh54f1hsjy6ahsq16"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@ -86,9 +85,11 @@
("kxmlgui" ,kxmlgui)
;; TODO: telepathy
("oxygen-icons" ,oxygen-icons) ; default icon set
("purpose" ,purpose)
("qca" ,qca)
("qoauth" ,qoauth)
("qtbase" ,qtbase)
("qtnetworkauth" ,qtnetworkauth)
("qtwebkit" ,qtwebkit)
("sonnet" ,sonnet)))
(home-page "https://kde.org/applications/internet/org.kde.choqok")

View File

@ -1,89 +0,0 @@
Add QMap include to fix building under Qt 5.13
This combines several patches which all add the same missing include:
- e13ab06f65a4e8b6259bccda1401abb9c1c9fdca
- 546ede9ef712bb1b156a55ce30df81c3203dde61
- 08fb06b63a78888e6703de6ac1a4fd6a0e2791eb
- bef6784596bf0b41287ebad81f138e1c8c2a6be2
Include is no longer added transitively.
---
--- a/plugins/betternotify/notify.h
+++ b/plugins/betternotify/notify.h
@@ -23,6 +23,7 @@
#ifndef NOTIFY_H
#define NOTIFY_H
+#include <QMap>
#include <QQueue>
#include <QPoint>
#include <QPointer>
--- a/plugins/untiny/untiny.h
+++ b/plugins/untiny/untiny.h
@@ -27,6 +27,7 @@
#include "plugin.h"
+#include <QMap>
#include <QQueue>
#include <QUrl>
#include <QPointer>
--- a/plugins/uploaders/flickr/flickr.h
+++ b/plugins/uploaders/flickr/flickr.h
@@ -26,6 +26,8 @@
#include "uploader.h"
+#include <QMap>
+
/**
@author Andrey Esin \<gmlastik@gmail.com\>
*/
diff --git a/plugins/uploaders/imageshack/imageshack.h b/plugins/uploaders/imageshack/imageshack.h
index d9ddc88..63d0e3f 100644
--- a/plugins/uploaders/imageshack/imageshack.h
+++ b/plugins/uploaders/imageshack/imageshack.h
@@ -26,6 +26,8 @@
#include "uploader.h"
+#include <QMap>
+
/**
@author Mehrdad Momeny \<mehrdad.momeny@gmail.com\>
*/
--- a/plugins/uploaders/mobypicture/mobypicture.h
+++ b/plugins/uploaders/mobypicture/mobypicture.h
@@ -26,6 +26,8 @@
#include "uploader.h"
+#include <QMap>
+
class KJob;
class Mobypicture : public Choqok::Uploader
--- a/plugins/uploaders/posterous/posterous.h
+++ b/plugins/uploaders/posterous/posterous.h
@@ -26,6 +26,8 @@
#include "uploader.h"
+#include <QMap>
+
class KJob;
class Posterous : public Choqok::Uploader
--- a/plugins/uploaders/twitgoo/twitgoo.h
+++ b/plugins/uploaders/twitgoo/twitgoo.h
@@ -26,6 +26,8 @@
#include "uploader.h"
+#include <QMap>
+
class KJob;
class Twitgoo : public Choqok::Uploader
--