gnu: Add openjdk13.

* gnu/packages/java.scm (openjdk13): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
This commit is contained in:
Not Zed 2020-04-28 10:33:46 +09:30 committed by Ricardo Wurmus
parent c582741336
commit c4618174ec
No known key found for this signature in database
GPG Key ID: 197A5888235FACAC
2 changed files with 53 additions and 0 deletions

View File

@ -2259,6 +2259,48 @@ new Date();"))
("zip" ,zip)))
(home-page "https://openjdk.java.net/projects/jdk/12")))
(define-public openjdk13
(package
(inherit openjdk12)
(name "openjdk")
(version "13.0")
(source (origin
(method url-fetch)
(uri "http://hg.openjdk.java.net/jdk/jdk13/archive/9c250a7600e1.tar.bz2")
(file-name (string-append name "-" version ".tar.bz2"))
(sha256
(base32
"0v0ljvx5dyzp96dw4z4ksw3pvasil7783mgnmd1wk9gads5ab8iq"))
(modules '((guix build utils)))
(snippet
`(begin
(for-each delete-file (find-files "." ".*.(bin|exe|jar)$"))
#t))))
(inputs
`(("alsa-lib" ,alsa-lib)
("cups" ,cups)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("giflib" ,giflib)
("lcms" ,lcms)
("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libx11" ,libx11)
("libxext" ,libxext)
("libxrandr" ,libxrandr)
("libxrender" ,libxrender)
("libxt" ,libxt)
("libxtst" ,libxtst)))
(native-inputs
`(("autoconf" ,autoconf)
("openjdk12:jdk" ,openjdk12 "jdk")
("make@4.2" ,gnu-make-4.2)
("pkg-config" ,pkg-config)
("unzip" ,unzip)
("which" ,which)
("zip" ,zip)))
(home-page "https://openjdk.java.net/projects/jdk/13")))
(define-public icedtea icedtea-8)

View File

@ -0,0 +1,11 @@
--- jdk14-bc54620a3848/make/autoconf/basics.m4 2020-02-07 04:40:54.000000000 +1030
+++ jdk14-bc54620a3848-new/make/autoconf/basics.m4 2020-04-24 10:59:33.056098506 +0930
@@ -583,7 +583,7 @@
BASIC_SETUP_TOOL($1, [AC_PATH_PROGS($1, $2, , $3)])
if test "x[$]$1" = x; then
AC_MSG_NOTICE([Required tool $2 not found in PATH, checking built-in])
- if help $2 > /dev/null 2>&1; then
+ if command -v $2 > /dev/null 2>&1; then
AC_MSG_NOTICE([Found $2 as shell built-in. Using it])
$1="$2"
else