Merge branch 'master' into core-updates
This commit is contained in:
commit
c6d02bcf1b
@ -256,7 +256,6 @@ GNU_SYSTEM_MODULES = \
|
||||
%D%/packages/haskell-crypto.scm \
|
||||
%D%/packages/haskell-web.scm \
|
||||
%D%/packages/haskell-xyz.scm \
|
||||
%D%/packages/ham-radio.scm \
|
||||
%D%/packages/hexedit.scm \
|
||||
%D%/packages/hugs.scm \
|
||||
%D%/packages/hurd.scm \
|
||||
@ -435,6 +434,7 @@ GNU_SYSTEM_MODULES = \
|
||||
%D%/packages/toys.scm \
|
||||
%D%/packages/tryton.scm \
|
||||
%D%/packages/qt.scm \
|
||||
%D%/packages/radio.scm \
|
||||
%D%/packages/ragel.scm \
|
||||
%D%/packages/rails.scm \
|
||||
%D%/packages/ratpoison.scm \
|
||||
@ -463,7 +463,6 @@ GNU_SYSTEM_MODULES = \
|
||||
%D%/packages/scsi.scm \
|
||||
%D%/packages/sdcc.scm \
|
||||
%D%/packages/sdl.scm \
|
||||
%D%/packages/sdr.scm \
|
||||
%D%/packages/search.scm \
|
||||
%D%/packages/security-token.scm \
|
||||
%D%/packages/selinux.scm \
|
||||
@ -832,6 +831,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/date-output-pkg-config-files.patch \
|
||||
%D%/packages/patches/darkice-workaround-fpermissive-error.patch \
|
||||
%D%/packages/patches/datefudge-gettimeofday.patch \
|
||||
%D%/packages/patches/dbacl-include-locale.h.patch \
|
||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||
%D%/packages/patches/dbus-c++-gcc-compat.patch \
|
||||
%D%/packages/patches/dbus-c++-threading-mutex.patch \
|
||||
|
@ -1049,13 +1049,13 @@ (define-public python2-stdnum
|
||||
(define-public python-duniterpy
|
||||
(package
|
||||
(name "python-duniterpy")
|
||||
(version "0.56.0")
|
||||
(version "0.57.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "duniterpy" version))
|
||||
(sha256
|
||||
(base32 "1h8d8cnr6k5sw4cqy8r82zy4ldzpvn4nlk2221lz2haqq7xm4s5z"))))
|
||||
(base32 "0rw2c7r9gcqhymp82gbk1ky45zqbypsi2q5x4vdwjc6g00kh7h6l"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
;; FIXME: Tests fail with: "ModuleNotFoundError: No module named
|
||||
|
@ -3706,6 +3706,69 @@ (define-public lierolibre
|
||||
;; Code mainly BSD-2, some parts under Boost 1.0. All assets are WTFPL2.
|
||||
(license (list license:bsd-2 license:boost1.0 license:wtfpl2))))
|
||||
|
||||
(define-public tennix
|
||||
(package
|
||||
(name "tennix")
|
||||
(version "1.3.1")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://repo.or.cz/tennix.git")
|
||||
(commit (string-append "tennix-" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "02cj4lrdrisal5s9pnbf2smx7qz9czczjzndfkhfx0qy67b957sk"))
|
||||
;; Remove non-free images.
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
(for-each delete-file
|
||||
'("data/loc_training_camp.png"
|
||||
"data/loc_austrian_open.png"
|
||||
"data/loc_olympic_green_tennis.png"))
|
||||
#t))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f ;no test
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-include
|
||||
(lambda _
|
||||
(substitute* '("src/graphics.h" "src/sound.h")
|
||||
(("#include \"(SDL_(image|ttf|mixer)\\.h)\"" _ header)
|
||||
(string-append "#include \"SDL/" header "\"")))
|
||||
(substitute* '("src/tennix.h" "src/network.h" "src/SDL_rotozoom.h")
|
||||
(("#include <SDL.h>") "#include <SDL/SDL.h>")
|
||||
(("#include <SDL_net.h>") "#include <SDL/SDL_net.h>"))
|
||||
#t))
|
||||
(add-after 'unpack 'locate-install
|
||||
;; Build process cannot expand "$(INSTALL)" in Makefile.
|
||||
(lambda _
|
||||
(substitute* "makefile"
|
||||
(("^CONFIGURE_OUTPUT :=.*" all)
|
||||
(string-append "INSTALL := install -c\n" all)))
|
||||
#t))
|
||||
(replace 'configure
|
||||
;; The "configure" script is picky about the arguments it
|
||||
;; gets. Call it ourselves.
|
||||
(lambda _
|
||||
(invoke "./configure" "--prefix" (assoc-ref %outputs "out")))))))
|
||||
(native-inputs
|
||||
`(("which" ,which)))
|
||||
(inputs
|
||||
`(("python" ,python-wrapper)
|
||||
("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf sdl-net)))))
|
||||
(home-page "http://icculus.org/tennix/")
|
||||
(synopsis "Play tennis against the computer or a friend")
|
||||
(description "Tennix is a 2D tennis game. You can play against the
|
||||
computer or against another player using the keyboard. The game runs
|
||||
in-window at 640x480 resolution or fullscreen.")
|
||||
;; Project is licensed under GPL2+ terms. It includes images
|
||||
;; released under Public Domain terms, and SDL_rotozoom, released
|
||||
;; under LGPL2.1 terms.
|
||||
(license (list license:gpl2+ license:public-domain license:lgpl2.1))))
|
||||
|
||||
(define-public warzone2100
|
||||
(package
|
||||
(name "warzone2100")
|
||||
@ -3762,7 +3825,7 @@ (define-public warzone2100
|
||||
modes. An extensive tech tree with over 400 different technologies, combined
|
||||
with the unit design system, allows for a wide variety of possible units and
|
||||
tactics.")
|
||||
; Everything is GPLv2+ unless otherwise specified in COPYING.NONGPL
|
||||
; Everything is GPLv2+ unless otherwise specified in COPYING.NONGPL
|
||||
(license (list license:bsd-3
|
||||
license:cc0
|
||||
license:cc-by-sa3.0
|
||||
@ -4008,7 +4071,7 @@ (define-public tuxpaint-config
|
||||
(define-public supertux
|
||||
(package
|
||||
(name "supertux")
|
||||
(version "0.6.1")
|
||||
(version "0.6.1.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/SuperTux/supertux/"
|
||||
@ -4017,7 +4080,7 @@ (define-public supertux
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0lqch5gcq6ccnspy93z9r13bp8w2j1vrd8jhvk5kp4qhrd1f069s"))
|
||||
"0n36qxwjlkdlksximz4s729az6pry2sdjavwgm7m65vfgdiz139f"))
|
||||
(patches
|
||||
(search-patches "supertux-unbundle-squirrel.patch"))))
|
||||
(arguments
|
||||
|
@ -5076,8 +5076,8 @@ (define-public ecl-cl-quickcheck
|
||||
(sbcl-package->ecl-package sbcl-cl-quickcheck))
|
||||
|
||||
(define-public sbcl-burgled-batteries3
|
||||
(let ((commit "9c0f6667e1a71ddf77e21793a0bea524710fef6e")
|
||||
(revision "1"))
|
||||
(let ((commit "f65f454d13bb6c40e17e9ec62e41eb5069e09760")
|
||||
(revision "2"))
|
||||
(package
|
||||
(name "sbcl-burgled-batteries3")
|
||||
(version (git-version "0.0.0" revision commit))
|
||||
@ -5090,33 +5090,33 @@ (define-public sbcl-burgled-batteries3
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0b726kz2xxcg5l930gz035rsdvhxrzmp05iwfwympnb4z4ammicb"))))
|
||||
"1nzn7jawrfajyzwfnzrg2cmn9xxadcqh4szbpg0jggkhdkdzz4wa"))))
|
||||
(build-system asdf-build-system/sbcl)
|
||||
(arguments
|
||||
'(#:tests? #f
|
||||
`(#:tests? #f
|
||||
#:modules (((guix build python-build-system) #:select (python-version))
|
||||
,@%asdf-build-system-modules)
|
||||
#:imported-modules ((guix build python-build-system)
|
||||
,@%asdf-build-system-modules)
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(modify-phases (@ (guix build asdf-build-system) %standard-phases)
|
||||
(add-after 'unpack 'set-*cpython-include-dir*-var
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "grovel-include-dir.lisp"
|
||||
(("\\(defparameter \\*cpython-include-dir\\* \\(detect-python\\)\\)")
|
||||
(string-append
|
||||
"(defparameter *cpython-include-dir* \""
|
||||
(assoc-ref inputs "python")
|
||||
"/include/python3.7m"
|
||||
"\")")))
|
||||
(substitute* "ffi-interface.lisp"
|
||||
(("\\*cpython-lib\\*")
|
||||
(format #f "'(\"~a/lib/libpython3.so\")"
|
||||
(assoc-ref inputs "python"))))
|
||||
#t)))))
|
||||
(let ((python (assoc-ref inputs "python")))
|
||||
(setenv "BB_PYTHON3_INCLUDE_DIR"
|
||||
(string-append python "/include/python"
|
||||
(python-version python)
|
||||
"m"))
|
||||
(setenv "BB_PYTHON3_DYLIB"
|
||||
(string-append python "/lib/libpython3.so"))
|
||||
#t))))))
|
||||
(native-inputs
|
||||
`(("python" ,python)
|
||||
("sbcl-cl-fad" ,sbcl-cl-fad)
|
||||
`(("sbcl-cl-fad" ,sbcl-cl-fad)
|
||||
("sbcl-lift" ,sbcl-lift)
|
||||
("sbcl-cl-quickcheck" ,sbcl-cl-quickcheck)))
|
||||
(inputs
|
||||
`(("sbcl-cffi" ,sbcl-cffi)
|
||||
`(("python" ,python)
|
||||
("sbcl-cffi" ,sbcl-cffi)
|
||||
("sbcl-cffi-grovel" ,sbcl-cffi-grovel)
|
||||
("sbcl-alexandria" , sbcl-alexandria)
|
||||
("sbcl-parse-declarations-1.0" ,sbcl-parse-declarations)
|
||||
@ -5126,7 +5126,6 @@ (define-public sbcl-burgled-batteries3
|
||||
"This package provides a shim between Python3 (specifically, the
|
||||
CPython implementation of Python) and Common Lisp.")
|
||||
(home-page "https://github.com/snmsts/burgled-batteries3")
|
||||
;; MIT
|
||||
(license license:expat))))
|
||||
|
||||
(define-public cl-burgled-batteries3
|
||||
|
36
gnu/packages/patches/dbacl-include-locale.h.patch
Normal file
36
gnu/packages/patches/dbacl-include-locale.h.patch
Normal file
@ -0,0 +1,36 @@
|
||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Sat, 11 Apr 2020 03:02:04 +0200
|
||||
Subject: [PATCH] gnu: dbacl: Include <locale.h> in dbacl.h.
|
||||
|
||||
Copied verbatim[0] from Debian.
|
||||
|
||||
[0]: https://sources.debian.org/data/main/d/dbacl/1.14.1-2/debian/patches/05-locale-h.patch
|
||||
|
||||
Description: Add missing <locale.h> include in dbacl.h
|
||||
Author: Fabian Wolff <fabi.wolff@arcor.de>
|
||||
Bug-Debian: https://bugs.debian.org/916182
|
||||
Last-Update: 2019-08-25
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- a/src/dbacl.h
|
||||
+++ b/src/dbacl.h
|
||||
@@ -21,6 +21,8 @@
|
||||
#ifndef DBACL_H
|
||||
#define DBACL_H
|
||||
|
||||
+#include <locale.h>
|
||||
+
|
||||
#ifdef HAVE_CONFIG_H
|
||||
#undef HAVE_CONFIG_H
|
||||
#include "config.h"
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -28,7 +28,7 @@
|
||||
# stuff_SOURCES = stuff.c stuff.h fram.c stuff-lexer.l stuff-parser.y stuff-parser.h probs.c util.c util.h $(PUBDOM)
|
||||
# stuff_LDADD = @LEXLIB@
|
||||
|
||||
-AM_CFLAGS = -funsigned-char -std=c99 -Wall -pedantic $(CFLAGSIEEE) -O3
|
||||
+AM_CFLAGS = -funsigned-char -std=c99 -D_XOPEN_SOURCE=700 -Wall -pedantic $(CFLAGSIEEE) -O3
|
||||
AM_YFLAGS = -d
|
||||
|
||||
CLEANFILES = mailcross mailtoe mailfoot
|
@ -1774,13 +1774,13 @@ (define-public python2-webtest
|
||||
(define-public python-flask
|
||||
(package
|
||||
(name "python-flask")
|
||||
(version "1.1.1")
|
||||
(version "1.1.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "Flask" version))
|
||||
(sha256
|
||||
(base32
|
||||
"0ljdjgyjn7vh8ic1n1dc2l1cl421i6pr3kx5sz2w5irhyfbg3y8k"))))
|
||||
"0q3h295izcil7lswkzfnyg3k5gq4hpmqmpl6i7s5m1n9szi1myjf"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
'(#:phases
|
||||
@ -2672,7 +2672,7 @@ (define-public python-flask-migrate
|
||||
(define-public python-genshi
|
||||
(package
|
||||
(name "python-genshi")
|
||||
(version "0.7.2")
|
||||
(version "0.7.3")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
@ -2681,7 +2681,7 @@ (define-public python-genshi
|
||||
(commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "06rch30x10l105k5b6rahd839lkhmgrzn6691wbci0cb2fzps32w"))))
|
||||
(base32 "04bw7nd4wyn8ixnhik57hny2xpjjpn80k5hp6691inix5gc6rxaf"))))
|
||||
(build-system python-build-system)
|
||||
(home-page "https://genshi.edgewall.org/")
|
||||
(synopsis "Toolkit for generation of output for the web")
|
||||
|
@ -11752,14 +11752,14 @@ (define-public python2-lazy-object-proxy
|
||||
(define-public python-dnspython
|
||||
(package
|
||||
(name "python-dnspython")
|
||||
(version "1.15.0")
|
||||
(version "1.16.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://www.dnspython.org/kits/"
|
||||
version "/dnspython-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0jr4v2pd90i6l1xxbss2m05psbjaxvyvvvpq44wycijpfgjqln8i"))))
|
||||
"1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
|
||||
(build-system python-build-system)
|
||||
(arguments '(#:tests? #f)) ; XXX: requires internet access
|
||||
(home-page "http://www.dnspython.org")
|
||||
|
@ -2049,7 +2049,10 @@ (define-public python-pyqtwebengine
|
||||
("qtwebengine" ,qtwebengine)))
|
||||
(arguments
|
||||
`(#:modules ((srfi srfi-1)
|
||||
((guix build python-build-system) #:select (python-version))
|
||||
,@%gnu-build-system-modules)
|
||||
#:imported-modules ((guix build python-build-system)
|
||||
,@%gnu-build-system-modules)
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(replace 'configure
|
||||
@ -2059,13 +2062,8 @@ (define-public python-pyqtwebengine
|
||||
(pyqt-sipdir (string-append
|
||||
(assoc-ref inputs "python-pyqt") "/share/sip"))
|
||||
(python (assoc-ref inputs "python"))
|
||||
(python-version
|
||||
(last (string-split python #\-)))
|
||||
(python-major+minor
|
||||
(string-join
|
||||
(take (string-split python-version #\.) 2) "."))
|
||||
(lib (string-append out "/lib/python"
|
||||
python-major+minor
|
||||
(python-version python)
|
||||
"/site-packages/PyQt5"))
|
||||
(stubs (string-append lib "/PyQt5")))
|
||||
|
||||
@ -2084,7 +2082,9 @@ (define-public python-pyqtwebengine
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
(let* ((__init__.py (string-append
|
||||
(assoc-ref outputs "out")
|
||||
"/lib/python3.7/site-packages/PyQt5/__init__.py")))
|
||||
"/lib/python"
|
||||
(python-version (assoc-ref inputs "python"))
|
||||
"/site-packages/PyQt5/__init__.py")))
|
||||
(with-output-to-file __init__.py
|
||||
(lambda _ (display "
|
||||
from pkgutil import extend_path
|
||||
|
@ -1,5 +1,6 @@
|
||||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
|
||||
;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
|
||||
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
|
||||
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
|
||||
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
|
||||
@ -20,7 +21,7 @@
|
||||
;;; You should have received a copy of the GNU General Public License
|
||||
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
(define-module (gnu packages ham-radio)
|
||||
(define-module (gnu packages radio)
|
||||
#:use-module ((guix licenses) #:prefix license:)
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
@ -50,7 +51,6 @@ (define-module (gnu packages ham-radio)
|
||||
#:use-module (gnu packages python-science)
|
||||
#:use-module (gnu packages python-xyz)
|
||||
#:use-module (gnu packages qt)
|
||||
#:use-module (gnu packages sdr)
|
||||
#:use-module (gnu packages sphinx)
|
||||
#:use-module (gnu packages swig)
|
||||
#:use-module (gnu packages tex)
|
||||
@ -63,6 +63,36 @@ (define-module (gnu packages ham-radio)
|
||||
#:use-module (guix build-system python)
|
||||
#:use-module (guix build-system qt))
|
||||
|
||||
(define-public liquid-dsp
|
||||
(package
|
||||
(name "liquid-dsp")
|
||||
(version "1.3.2")
|
||||
(source
|
||||
(origin (method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/jgaeddert/liquid-dsp.git")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("autoconf" ,autoconf)))
|
||||
(inputs
|
||||
`(("fftw" ,fftw)
|
||||
("fftwf" ,fftwf)))
|
||||
(home-page "https://liquidsdr.org")
|
||||
(synopsis "Signal processing library for software-defined radios")
|
||||
(description
|
||||
"Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
|
||||
specifically for software-defined radios on embedded platforms. The aim is to
|
||||
provide a lightweight DSP library that does not rely on a myriad of external
|
||||
dependencies or proprietary and otherwise cumbersome frameworks. All signal
|
||||
processing elements are designed to be flexible, scalable, and dynamic,
|
||||
including filters, filter design, oscillators, modems, synchronizers, complex
|
||||
mathematical operations, and much more.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public rtl-sdr
|
||||
(package
|
||||
(name "rtl-sdr")
|
@ -1,57 +0,0 @@
|
||||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
|
||||
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
;;; GNU Guix is free software; you can redistribute it and/or modify it
|
||||
;;; under the terms of the GNU General Public License as published by
|
||||
;;; the Free Software Foundation; either version 3 of the License, or (at
|
||||
;;; your option) any later version.
|
||||
;;;
|
||||
;;; GNU Guix is distributed in the hope that it will be useful, but
|
||||
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
;;; GNU General Public License for more details.
|
||||
;;;
|
||||
;;; You should have received a copy of the GNU General Public License
|
||||
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
(define-module (gnu packages sdr)
|
||||
#:use-module ((guix licenses) #:prefix license:)
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix git-download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages algebra)
|
||||
#:use-module (gnu packages autotools))
|
||||
|
||||
(define-public liquid-dsp
|
||||
(package
|
||||
(name "liquid-dsp")
|
||||
(version "1.3.2")
|
||||
(source
|
||||
(origin (method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/jgaeddert/liquid-dsp.git")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("autoconf" ,autoconf)))
|
||||
(inputs
|
||||
`(("fftw" ,fftw)
|
||||
("fftwf" ,fftwf)))
|
||||
(home-page "https://liquidsdr.org")
|
||||
(synopsis "Signal processing library for software-defined radios")
|
||||
(description
|
||||
"Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
|
||||
specifically for software-defined radios on embedded platforms. The aim is to
|
||||
provide a lightweight DSP library that does not rely on a myriad of external
|
||||
dependencies or proprietary and otherwise cumbersome frameworks. All signal
|
||||
processing elements are designed to be flexible, scalable, and dynamic,
|
||||
including filters, filter design, oscillators, modems, synchronizers, complex
|
||||
mathematical operations, and much more.")
|
||||
(license license:expat)))
|
@ -1,6 +1,7 @@
|
||||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2016 Petter <petter@mykolab.ch>
|
||||
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -30,7 +31,7 @@ (define-module (gnu packages syncthing)
|
||||
(define-public syncthing
|
||||
(package
|
||||
(name "syncthing")
|
||||
(version "1.4.1")
|
||||
(version "1.4.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/syncthing/syncthing"
|
||||
@ -38,7 +39,7 @@ (define-public syncthing
|
||||
"/syncthing-source-v" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0p1855n29rin2y8bjvmr7gkm18xd2j7js15l8nqcmyd33d60568z"))
|
||||
"16dqpbn4saxmmmqd5ya8zdkwvxzz4nim1p4w954zkkdz3cyg86h6"))
|
||||
(modules '((guix build utils)))
|
||||
;; Delete bundled ("vendored") free software source code.
|
||||
(snippet '(begin
|
||||
@ -97,7 +98,7 @@ (define-public syncthing
|
||||
("go-github-com-lucas-clemente-quic-go" ,go-github-com-lucas-clemente-quic-go)
|
||||
("go-github-com-willf-bloom" ,go-github-com-willf-bloom)
|
||||
|
||||
;; For tests
|
||||
;; For tests.
|
||||
("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
|
||||
|
||||
(arguments
|
||||
|
@ -13,7 +13,7 @@
|
||||
;;; Copyright © 2017,2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
|
||||
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
|
||||
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
|
||||
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
|
||||
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
|
||||
;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
|
||||
@ -612,15 +612,15 @@ (define-public utfcpp
|
||||
(define-public dbacl
|
||||
(package
|
||||
(name "dbacl")
|
||||
(version "1.14")
|
||||
(version "1.14.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://www.lbreyer.com/gpl/"
|
||||
(uri (string-append "mirror://sourceforge/dbacl/dbacl/" version "/"
|
||||
"dbacl-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0224g6x71hyvy7jikfxmgcwww1r5lvk0jx36cva319cb9nmrbrq7"))))
|
||||
(base32 "1gas0112wqjvwn9qg3hxnawk7h3prr0w9b2h68f3p1ifd1kzn3gz"))
|
||||
(patches (search-patches "dbacl-include-locale.h.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:make-flags
|
||||
@ -648,10 +648,6 @@ (define-public dbacl
|
||||
(lambda _
|
||||
(delete-file "src/tests/dbacl-jap.shin")
|
||||
#t))
|
||||
(add-after 'delete-sample6-and-japanese 'autoreconf
|
||||
(lambda _
|
||||
(invoke "autoreconf" "-vif")
|
||||
#t))
|
||||
(add-after 'unpack 'fix-test-files
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
(let* ((out (assoc-ref outputs "out"))
|
||||
@ -661,7 +657,11 @@ (define-public dbacl
|
||||
"#PATH=/bin:/usr/bin")
|
||||
(("diff") (string-append (which "diff")))
|
||||
(("tr") (string-append (which "tr"))))
|
||||
#t))))))
|
||||
#t)))
|
||||
(replace 'bootstrap
|
||||
(lambda _
|
||||
(invoke "autoreconf" "-vif")
|
||||
#t)))))
|
||||
(inputs
|
||||
`(("ncurses" ,ncurses)
|
||||
("perl" ,perl)
|
||||
|
@ -251,7 +251,7 @@ (define-public gnutls
|
||||
(properties '((ftp-server . "ftp.gnutls.org")
|
||||
(ftp-directory . "/gcrypt/gnutls")))))
|
||||
|
||||
(define gnutls-3.6.13
|
||||
(define-public gnutls-3.6.13
|
||||
(package
|
||||
(inherit gnutls)
|
||||
(version "3.6.13")
|
||||
|
@ -1988,7 +1988,7 @@ (define-public reposurgeon
|
||||
(define-public tig
|
||||
(package
|
||||
(name "tig")
|
||||
(version "2.5.0")
|
||||
(version "2.5.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
@ -1996,7 +1996,7 @@ (define-public tig
|
||||
version "/tig-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1x5famvvs93ih7sr11x7m33dksb1k7zs1s3c4zkyf0cjmxkpqlzz"))))
|
||||
"0r4y9hyvpkplaxrzslws3asz652d83qh3bjwvmp8assga8s5s3ah"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("asciidoc" ,asciidoc)
|
||||
@ -2010,8 +2010,8 @@ (define-public tig
|
||||
(add-after 'install 'install-doc
|
||||
(lambda _
|
||||
(invoke "make" "install-doc"))))
|
||||
#:tests? #f)) ; tests require access to /dev/tty
|
||||
;; #:test-target "test"))
|
||||
#:test-target "test"
|
||||
#:tests? #f)) ; tests require access to /dev/tty
|
||||
(home-page "https://jonas.github.io/tig/")
|
||||
(synopsis "Ncurses-based text user interface for Git")
|
||||
(description
|
||||
|
@ -758,7 +758,7 @@ (define-public libcaca
|
||||
(define-public libdca
|
||||
(package
|
||||
(name "libdca")
|
||||
(version "0.0.6")
|
||||
(version "0.0.7")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
@ -766,8 +766,12 @@ (define-public libdca
|
||||
version "/libdca-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0h0zvcn97i9kyljdpifzi8in9xnw31fx3b3ggj96p8h0l2d8mycq"))))
|
||||
"0sjz0s0nrv7jcpvh1i432x3jza0y5yycmzw84cfncb2qby0i62rs"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("autoconf" ,autoconf)
|
||||
("automake" ,automake)
|
||||
("libtool" ,libtool)))
|
||||
(home-page "https://www.videolan.org/developers/libdca.html")
|
||||
(synopsis "DTS Coherent Acoustics decoder")
|
||||
(description "libdca is a library for decoding DTS Coherent Acoustics
|
||||
|
@ -1093,7 +1093,7 @@ (define-public python-vagrant
|
||||
(define-public bubblewrap
|
||||
(package
|
||||
(name "bubblewrap")
|
||||
(version "0.4.0")
|
||||
(version "0.4.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/containers/bubblewrap/"
|
||||
@ -1101,7 +1101,7 @@ (define-public bubblewrap
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"08r0f4c3fjkb4zjrb4kkax1zfcgcgic702vb62sjjw5xfhppvzp5"))))
|
||||
"00ycgi6q2yngh06bnz50wkvar6r2jnjf3j158grhi9k13jdrpimr"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
@ -243,17 +243,17 @@ (define-public ocproxy
|
||||
(define-public openconnect
|
||||
(package
|
||||
(name "openconnect")
|
||||
(version "8.05")
|
||||
(version "8.08")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
|
||||
"openconnect-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "14i9q727c2zc9xhzp1a9hz3gzb5lwgsslbhircm84dnbs192jp1k"))))
|
||||
(base32 "1s3rjdazx1n5izpcgz05p1sirm7kf4z3gh26dq2h2j5xmgmk0jxp"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("libxml2" ,libxml2)
|
||||
("gnutls" ,gnutls)
|
||||
("gnutls" ,gnutls-3.6.13)
|
||||
("zlib" ,zlib)))
|
||||
(inputs
|
||||
`(("vpnc-scripts" ,vpnc-scripts)))
|
||||
|
@ -647,7 +647,7 @@ (define-public xfce4-settings
|
||||
(define-public thunar
|
||||
(package
|
||||
(name "thunar")
|
||||
(version "1.8.12")
|
||||
(version "1.8.14")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://archive.xfce.org/src/xfce/"
|
||||
@ -655,7 +655,7 @@ (define-public thunar
|
||||
"thunar-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1y1548jrx93c9v8ks60mkd9sx5xl69fmwh1pbr9gsnqz1gp5na99"))))
|
||||
"17r1z8cyp709lz38w7b5vqi1zbgm2i3sqvdvicsbvma2b0gppica"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
|
Loading…
Reference in New Issue
Block a user