gnu: calibre: Disable sqlite test.

* gnu/packages/patches/calibre-remove-test-sqlite.patch: New file.
* gnu/packages/ebook.scm (calibre)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
This commit is contained in:
Brendan Tildesley 2019-05-04 02:42:23 +10:00 committed by Danny Milosavljevic
parent 4bcd0647b7
commit cbe399e736
No known key found for this signature in database
GPG Key ID: E71A35542C30BAA5
3 changed files with 31 additions and 0 deletions

View File

@ -691,6 +691,7 @@ dist_patch_DATA = \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
%D%/packages/patches/calibre-remove-test-bs4.patch \
%D%/packages/patches/calibre-remove-test-sqlite.patch \
%D%/packages/patches/calibre-remove-test-unrar.patch \
%D%/packages/patches/casync-renameat2-declaration.patch \
%D%/packages/patches/catdoc-CVE-2017-11110.patch \

View File

@ -98,6 +98,7 @@
#t))
(patches (search-patches "calibre-no-updates-dialog.patch"
"calibre-remove-test-bs4.patch" ; TODO: fix test.
"calibre-remove-test-sqlite.patch" ; TODO: fix test.
"calibre-remove-test-unrar.patch"))))
(build-system python-build-system)
(native-inputs

View File

@ -0,0 +1,29 @@
From a92e26359bd07743ab105819ed0b619e27e14017 Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <mail@brendan.scot>
Date: Sat, 27 Apr 2019 03:30:53 +1000
Subject: [PATCH] Disable test_sqlite.
---
src/calibre/test_build.py | 6 ------
1 file changed, 6 deletions(-)
diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
index 07bdffd3e5..740588c95b 100644
--- a/src/calibre/test_build.py
+++ b/src/calibre/test_build.py
@@ -162,12 +162,6 @@ class BuildTest(unittest.TestCase):
au(x, 'strftime')
self.assertEqual(unicode_type(time.strftime(fmt.replace('%e', '%#d'), t)), x)
- def test_sqlite(self):
- import sqlite3
- conn = sqlite3.connect(':memory:')
- from calibre.library.sqlite import load_c_extensions
- self.assertTrue(load_c_extensions(conn, True), 'Failed to load sqlite extension')
-
def test_apsw(self):
import apsw
conn = apsw.Connection(':memory:')
--
2.21.0