gnu: knot: Update to 2.8.0.

* gnu/packages/dns.scm (knot): Update to 2.8.0.
[source]: Add patch.
* gnu/packages/patches/knot-include-system-lmdb-header.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
Tobias Geerinckx-Rice 2019-03-20 00:13:57 +01:00
parent 1c4d4196c2
commit d17b1c0891
No known key found for this signature in database
GPG Key ID: 0DB0FF884F556D79
3 changed files with 39 additions and 2 deletions

View File

@ -929,6 +929,7 @@ dist_patch_DATA = \
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
%D%/packages/patches/knot-include-system-lmdb-header.patch \
%D%/packages/patches/kpackage-allow-external-paths.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \

View File

@ -569,14 +569,16 @@ Extensions} (DNSSEC).")
(define-public knot
(package
(name "knot")
(version "2.7.6")
(version "2.8.0")
(source (origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-dns/"
"knot-" version ".tar.xz"))
(sha256
(base32
"18lpyq3vgr2ainmfiy14x7hcf1zxza66bhkpr54jaz2gy1viijx1"))
"1vw7xx7bm440jwrpvdd04vrp6ccz2b11swcn9msvs62hf0kdjjj9"))
(patches
(search-patches "knot-include-system-lmdb-header.patch"))
(modules '((guix build utils)))
(snippet
'(begin

View File

@ -0,0 +1,34 @@
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Wed, 20 Mar 2019 00:08:00 +0100
Subject: [PATCH] gnu: knot: Include system <lmdb.h>.
Copied verbatim from Knot master[0].
[0]: https://gitlab.labs.nic.cz/knot/knot-dns/commit/b557430cffbb1c6b30617a394b02acc514e7e536
From b557430cffbb1c6b30617a394b02acc514e7e536 Mon Sep 17 00:00:00 2001
From: Daniel Salzman <daniel.salzman@nic.cz>
Date: Wed, 6 Mar 2019 17:35:44 +0100
Subject: [PATCH] journal: include proper header <lmdb.h>
fixes #638
---
src/knot/journal/knot_lmdb.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/knot/journal/knot_lmdb.h b/src/knot/journal/knot_lmdb.h
index 35a88845c..b1d09cbb4 100644
--- a/src/knot/journal/knot_lmdb.h
+++ b/src/knot/journal/knot_lmdb.h
@@ -16,7 +16,7 @@
#pragma once
-#include "contrib/lmdb/lmdb.h"
+#include <lmdb.h>
#include <stdbool.h>
#include <stdlib.h>
--
2.18.1