gnu: java-openjfx-build: Add helpful patch.

* gnu/packages/java.scm (java-openjfx-build)[source]: Use it.
* gnu/packages/patches/java-openjfx-build-jdk_version.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Alexey Abramov <levenson@mmer.org>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Alexey Abramov 2020-05-30 19:09:43 +02:00 committed by Ludovic Courtès
parent b6c445931e
commit d9ef5aeba7
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 30 additions and 1 deletions

View File

@ -1111,6 +1111,7 @@ dist_patch_DATA = \
%D%/packages/patches/java-apache-ivy-port-to-latest-bouncycastle.patch \
%D%/packages/patches/java-commons-collections-fix-java8.patch \
%D%/packages/patches/java-jeromq-fix-tests.patch \
%D%/packages/patches/java-openjfx-build-jdk_version.patch \
%D%/packages/patches/java-powermock-fix-java-files.patch \
%D%/packages/patches/java-simple-xml-fix-tests.patch \
%D%/packages/patches/java-svg-salamander-Fix-non-det.patch \

View File

@ -2499,7 +2499,8 @@ new Date();"))
#t))
(sha256
(base32
"0yg38mwpivswccv9n96k06x3iv82i4px1a9xg9l8dswzwmfj259f"))))
"0yg38mwpivswccv9n96k06x3iv82i4px1a9xg9l8dswzwmfj259f"))
(patches (search-patches "java-openjfx-build-jdk_version.patch"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "java-openjfx.jar"

View File

@ -0,0 +1,27 @@
Subject: [PATCH] openjfx: Determine the version of Java in JDK_HOME
Icedtea contains guix in its version, so build.gradle failes to run. Openjfx
packaging is not trivial, so you will probably need to try build it with
gradlew.
---
build.gradle | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/build.gradle b/build.gradle
index df82f63..2c626cd 100644
--- a/build.gradle
+++ b/build.gradle
@@ -742,9 +742,9 @@ try {
if (inStream.readLine() != null) {
String v = inStream.readLine();
if (v != null) {
- int ib = v.indexOf(" (build ");
+ int ib = v.indexOf(" (guix build ");
if (ib != -1) {
- String ver = v.substring(ib + 8, v.size() - 1);
+ String ver = v.substring(ib + 13, v.size() - 1);
defineProperty("jdkRuntimeVersion", ver)
defineProperty("jdkVersion", jdkRuntimeVersion.split("-")[0])
2.24.1