gnu: aegisub: Fix build with Make 4.3.

* gnu/packages/patches/aegisub-make43.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/video.scm (aegisub)[source](patches): Add it.
This commit is contained in:
Marius Bakke 2020-04-10 17:15:32 +02:00
parent 29c6fb0d33
commit e43e980f84
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 23 additions and 1 deletions

View File

@ -722,7 +722,8 @@ dist_patch_DATA = \
%D%/packages/patches/aegis-test-fixup-1.patch \
%D%/packages/patches/aegis-test-fixup-2.patch \
%D%/packages/patches/aegisub-icu59-include-unistr.patch \
%D%/packages/patches/aegisub-boost68.patch \
%D%/packages/patches/aegisub-boost68.patch \
%D%/packages/patches/aegisub-make43.patch \
%D%/packages/patches/agg-am_c_prototype.patch \
%D%/packages/patches/akonadi-paths.patch \
%D%/packages/patches/akonadi-Revert-Make-installation-properly-relo.patch \

View File

@ -0,0 +1,20 @@
Fix build with GNU Make 4.3:
https://github.com/Aegisub/Aegisub/issues/171
Patch taken from upstream:
https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39
diff --git a/Makefile.target b/Makefile.target
--- a/Makefile.target
+++ b/Makefile.target
@@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
# Libraries contain all object files they depend on (but they may depend on other files)
# Not using libtool on OS X because it has an unsilenceable warning about a
# compatibility issue with BSD 4.3 (wtf)
-lib%.a: $$($$*_OBJ)
+lib%.a: $$($$(*F)_OBJ)
@$(BIN_MKDIR_P) $(dir $@)
$(BIN_AR) cru $@ $(filter %.o,$^)
$(BIN_RANLIB) $@

View File

@ -3249,6 +3249,7 @@ programmers to access a standard API to open and decompress media files.")
(base32
"11b83qazc8h0iidyj1rprnnjdivj1lpphvpa08y53n42bfa36pn5"))
(patches (search-patches "aegisub-icu59-include-unistr.patch"
"aegisub-make43.patch"
"aegisub-boost68.patch"))))
(build-system gnu-build-system)
(arguments