gnu: beets: Fix build with newer Werkzeug.

* gnu/packages/patches/beets-werkzeug-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/music.scm (beets)[source](patches): New field.
This commit is contained in:
Marius Bakke 2020-03-16 04:39:17 +01:00
parent 066c21cda4
commit e76cbdcd90
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 20 additions and 0 deletions

View File

@ -756,6 +756,7 @@ dist_patch_DATA = \
%D%/packages/patches/bash-completion-directories.patch \
%D%/packages/patches/bastet-change-source-of-unordered_set.patch \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
%D%/packages/patches/beets-werkzeug-compat.patch \
%D%/packages/patches/beignet-correct-file-names.patch \
%D%/packages/patches/benchmark-unbundle-googletest.patch \
%D%/packages/patches/biber-fix-encoding-write.patch \

View File

@ -2941,6 +2941,7 @@ Songs can be searched by artist, name or even by a part of the song text.")
(source (origin
(method url-fetch)
(uri (pypi-uri "beets" version))
(patches (search-patches "beets-werkzeug-compat.patch"))
(sha256
(base32
"0m40rjimvfgy1dv04p8f8d5dvi2855v4ix99a9xr900cmcn476yj"))))

View File

@ -0,0 +1,18 @@
Be compatible with python-werkzeug 1.0.0.
Taken from upstream:
https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
index f53fb3a954..21ff5d94ed 100644
--- a/beetsplug/web/__init__.py
+++ b/beetsplug/web/__init__.py
@@ -169,7 +169,7 @@ def to_python(self, value):
return ids
def to_url(self, value):
- return ','.join(value)
+ return ','.join(str(v) for v in value)
class QueryConverter(PathConverter):