gnu: datefudge: Fix compilation against libc 2.31.

* gnu/packages/patches/datefudge-gettimeofday.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/time.scm (datefudge)[source] Use it.
This commit is contained in:
Ludovic Courtès 2020-02-17 23:01:54 +01:00
parent 88f8549449
commit eb07edabaf
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 18 additions and 2 deletions

View File

@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Andreas Enge <andreas@enge.fr>
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
@ -806,6 +806,7 @@ dist_patch_DATA = \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
%D%/packages/patches/cyrus-sasl-ac-try-run-fix.patch \
%D%/packages/patches/darkice-workaround-fpermissive-error.patch \
%D%/packages/patches/datefudge-gettimeofday.patch \
%D%/packages/patches/dbus-helper-search-path.patch \
%D%/packages/patches/dbus-c++-gcc-compat.patch \
%D%/packages/patches/dbus-c++-threading-mutex.patch \

View File

@ -0,0 +1,13 @@
Add the 'restrict' qualifier to match the 'gettimeofday' declaration found
in glibc 2.31.
--- datefudge-1.23/datefudge.c 2020-02-17 22:35:21.343341725 +0100
+++ datefudge-1.23/datefudge.c 2020-02-17 22:35:49.619117874 +0100
@@ -78,6 +78,6 @@
return 0;
}
-int gettimeofday(struct timeval *x, struct timezone *y) {
+int gettimeofday(struct timeval *restrict x, void *restrict y) {
return __gettimeofday(x,y);
}

View File

@ -39,6 +39,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages perl)
@ -429,7 +430,8 @@ datetime type.")
(file-name (git-file-name name version))
(sha256
(base32
"0r9g8v9xnv60hq3j20wqy34kyig3sc2pisjxl4irn7jjx85f1spv"))))
"0r9g8v9xnv60hq3j20wqy34kyig3sc2pisjxl4irn7jjx85f1spv"))
(patches (search-patches "datefudge-gettimeofday.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"