gnu: vorbis-tools: Patch buffer overflow [fixes CVE-2015-6749].
* gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xiph.scm (vorbis-tools)[source]: Use it.
This commit is contained in:
parent
baacf042fd
commit
ef0f0d5f97
@ -770,6 +770,7 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/util-linux-tests.patch \
|
||||
gnu/packages/patches/upower-builddir.patch \
|
||||
gnu/packages/patches/valgrind-enable-arm.patch \
|
||||
gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch \
|
||||
gnu/packages/patches/vpnc-script.patch \
|
||||
gnu/packages/patches/vtk-mesa-10.patch \
|
||||
gnu/packages/patches/w3m-libgc.patch \
|
||||
|
44
gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
Normal file
44
gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch
Normal file
@ -0,0 +1,44 @@
|
||||
Upstream fix for CVE-2015-6749.
|
||||
https://trac.xiph.org/ticket/2212
|
||||
|
||||
From 04815d3e1bfae3a6cdfb2c25358a5a72b61299f7 Mon Sep 17 00:00:00 2001
|
||||
From: Mark Harris <mark.hsj@gmail.com>
|
||||
Date: Sun, 30 Aug 2015 05:54:46 -0700
|
||||
Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input
|
||||
|
||||
Fixes #2212
|
||||
---
|
||||
oggenc/audio.c | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/oggenc/audio.c b/oggenc/audio.c
|
||||
index 477da8c..4921fb9 100644
|
||||
--- a/oggenc/audio.c
|
||||
+++ b/oggenc/audio.c
|
||||
@@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] =
|
||||
int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
|
||||
{
|
||||
int aifc; /* AIFC or AIFF? */
|
||||
- unsigned int len;
|
||||
- unsigned char *buffer;
|
||||
+ unsigned int len, readlen;
|
||||
+ unsigned char buffer[22];
|
||||
unsigned char buf2[8];
|
||||
aiff_fmt format;
|
||||
aifffile *aiff = malloc(sizeof(aifffile));
|
||||
@@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
|
||||
return 0; /* Weird common chunk */
|
||||
}
|
||||
|
||||
- buffer = alloca(len);
|
||||
-
|
||||
- if(fread(buffer,1,len,in) < len)
|
||||
+ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
|
||||
+ if(fread(buffer,1,readlen,in) < readlen ||
|
||||
+ (len > readlen && !seek_forward(in, len-readlen)))
|
||||
{
|
||||
fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n"));
|
||||
return 0;
|
||||
--
|
||||
2.5.0
|
||||
|
@ -266,7 +266,8 @@ (define vorbis-tools
|
||||
"vorbis-tools-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))))
|
||||
"1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))
|
||||
(patches (list (search-patch "vorbis-tools-CVE-2015-6749.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("ao" ,ao)
|
||||
("curl" ,curl)
|
||||
|
Loading…
Reference in New Issue
Block a user