gnu: ghc-monad-par: Add a patch to fix tests on GHC 8.6.

* gnu/packages/patches/ghc-monad-par-fix-tests.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/haskell-xyz.scm (ghc-monad-par): Use it.
This commit is contained in:
Timothy Sample 2019-11-03 10:54:04 -05:00
parent 7fec7e6630
commit faac56f3af
No known key found for this signature in database
GPG Key ID: 2AC6A5EC1C357C59
3 changed files with 48 additions and 1 deletions

View File

@ -880,7 +880,8 @@ dist_patch_DATA = \
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
%D%/packages/patches/ghc-diff-swap-cover-args.patch \
%D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch \
%D%/packages/patches/ghc-haddock-library-unbundle.patch \
%D%/packages/patches/ghc-haddock-library-unbundle.patch \
%D%/packages/patches/ghc-monad-par-fix-tests.patch \
%D%/packages/patches/ghostscript-no-header-id.patch \
%D%/packages/patches/ghostscript-no-header-uuid.patch \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \

View File

@ -6541,6 +6541,7 @@ operators for looping.")
(uri (string-append "https://hackage.haskell.org/package/"
"monad-par-" version "/"
"monad-par-" version ".tar.gz"))
(patches (search-patches "ghc-monad-par-fix-tests.patch"))
(sha256
(base32
"0ldrzqy24fsszvn2a2nr77m2ih7xm0h9bgkjyv1l274aj18xyk7q"))))

View File

@ -0,0 +1,45 @@
This patch is taken from upstream. It fixes a test to work with GHC 8.6.
The paths have been slightly altered to work with the release tarball.
See <https://github.com/simonmar/monad-par/issues/66>.
From e20f81c8060208e4fb038e8f0e0668b41d72a6fb Mon Sep 17 00:00:00 2001
From: Clint Adams <clint@debian.org>
Date: Sat, 31 Aug 2019 14:12:34 -0400
Subject: [PATCH] Use a case statement instead of pattern-matching in
case_test_diamond
This avoids the need for a MonadFail instance. Closes #66
---
monad-par/tests/ParTests_shared.hs | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)
diff --git a/tests/ParTests_shared.hs b/tests/ParTests_shared.hs
index 31f438d..b2de50c 100644
--- a/tests/ParTests_shared.hs
+++ b/tests/ParTests_shared.hs
@@ -109,12 +109,15 @@ case_test_diamond :: Assertion
case_test_diamond = 9 @=? (m :: Int)
where
m = runPar $ do
- [a,b,c,d] <- sequence [new,new,new,new]
- fork $ do x <- get a; put b (x+1)
- fork $ do x <- get a; put c (x+2)
- fork $ do x <- get b; y <- get c; put d (x+y)
- fork $ do put a 3
- get d
+ abcd <- sequence [new,new,new,new]
+ case abcd of
+ [a,b,c,d] -> do
+ fork $ do x <- get a; put b (x+1)
+ fork $ do x <- get a; put c (x+2)
+ fork $ do x <- get b; y <- get c; put d (x+y)
+ fork $ do put a 3
+ get d
+ _ -> error "Oops"
-- | Violate IVar single-assignment:
--
--
2.23.0