gnu: Add java-groovy-bootstrap.

* gnu/packages/groovy.scm: New file.
* gnu/packages/patches/groovy-add-exceptionutilsgenerator.patch: New
file.
* gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Add them.
This commit is contained in:
Julien Lepiller 2018-03-13 20:31:01 +01:00
parent 27ba9760e0
commit fdc9170bc1
No known key found for this signature in database
GPG Key ID: 43111F4520086A0C
3 changed files with 197 additions and 0 deletions

View File

@ -202,6 +202,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/graphics.scm \
%D%/packages/graphviz.scm \
%D%/packages/groff.scm \
%D%/packages/groovy.scm \
%D%/packages/gsasl.scm \
%D%/packages/gstreamer.scm \
%D%/packages/gtk.scm \
@ -744,6 +745,7 @@ dist_patch_DATA = \
%D%/packages/patches/graphite2-ffloat-store.patch \
%D%/packages/patches/grep-timing-sensitive-test.patch \
%D%/packages/patches/groff-source-date-epoch.patch \
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
%D%/packages/patches/gsl-test-i686.patch \
%D%/packages/patches/gspell-dash-test.patch \
%D%/packages/patches/guile-1.8-cpp-4.5.patch \

97
gnu/packages/groovy.scm Normal file
View File

@ -0,0 +1,97 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages groovy)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system ant)
#:use-module (gnu packages)
#:use-module (gnu packages java)
#:use-module (gnu packages xml))
(define java-groovy-bootstrap
(package
(name "groovy-java-bootstrap")
(version "2.4.15")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/apache/groovy/archive/GROOVY_"
(string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"19f3yd2z6jmz1xhwi5kkg1wmgbqkfs7qvd3rzb43xr3nffz8cisv"))
(patches
(search-patches
"groovy-add-exceptionutilsgenerator.patch"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "groovy.jar"
#:source-dir "src/main:subprojects/groovy-test/src/main/java"
#:test-dir "src/test"
#:tests? #f
#:jdk ,icedtea-8
#:main-class "groovy.ui.GroovyMain"
#:phases
(modify-phases %standard-phases
(add-before 'build 'fix-java8
;; Fix "Reference to plus is ambiguous"
(lambda _
(substitute* "src/main/org/codehaus/groovy/runtime/DefaultGroovyMethods.java"
(("toList\\(left\\)")
"(List<T>)toList(left)"))
#t))
(add-before 'build 'generate-parsers
(lambda _
(with-directory-excursion "src/main/org/codehaus/groovy/antlr/java"
(invoke "antlr" "java.g"))
(with-directory-excursion "src/main/org/codehaus/groovy/antlr"
(mkdir "parser")
(with-directory-excursion "parser"
(invoke "antlr" "../groovy.g")))
#t))
(add-before 'build 'generate-exception-utils
(lambda _
(invoke "javac" "-cp" (getenv "CLASSPATH")
"config/ant/src/org/codehaus/groovy/ExceptionUtilsGenerator.java")
(invoke "java" "-cp" (string-append (getenv "CLASSPATH")
":config/ant/src")
"org.codehaus.groovy.ExceptionUtilsGenerator"
"build/classes/org/codehaus/groovy/runtime/ExceptionUtils.class")
#t)))))
(native-inputs
`(("java-junit" ,java-junit)
("java-hamcrest-core" ,java-hamcrest-core)
("antlr2" ,antlr2)
("java-jmock-1" ,java-jmock-1)
("java-xmlunit-legacy" ,java-xmlunit-legacy)))
(inputs
`(("java-commons-cli" ,java-commons-cli)
("java-asm" ,java-asm)
("java-classpathx-servletapi" ,java-classpathx-servletapi)
("java-xstream" ,java-xstream)
("java-jansi" ,java-jansi)
("java-jline-2" ,java-jline-2)))
(home-page "http://groovy-lang.org/")
(synopsis "Groovy's java bootstrap")
(description "This package contains the java bootstrap that is used to build
groovy submodules.")
(license license:asl2.0)))

View File

@ -0,0 +1,98 @@
From 3dbdc68093e90f0ef9b77b70490d8e0b1dcfbf8f Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sun, 17 Sep 2017 21:08:45 +0200
Subject: [PATCH] Add ExceptionUtilsGenerator.java.
A gradle task (in gradle/utils.gradle) is normally used to generate an
ExceptionUtils class. Since gradle depends on groovy, we cannot use it, so
we copy the code from the gradle task to a new file. Running this file then
generates the required class.
---
.../codehaus/groovy/ExceptionUtilsGenerator.java | 75 ++++++++++++++++++++++
1 file changed, 75 insertions(+)
create mode 100644 config/ant/src/org/codehaus/groovy/ExceptionUtilsGenerator.java
diff --git a/config/ant/src/org/codehaus/groovy/ExceptionUtilsGenerator.java b/config/ant/src/org/codehaus/groovy/ExceptionUtilsGenerator.java
new file mode 100644
index 0000000..41f006d
--- /dev/null
+++ b/config/ant/src/org/codehaus/groovy/ExceptionUtilsGenerator.java
@@ -0,0 +1,75 @@
+package org.codehaus.groovy;
+
+import org.objectweb.asm.*;
+
+import java.io.BufferedOutputStream;
+import java.io.File;
+import java.io.FileOutputStream;
+import java.io.IOException;
+import java.util.logging.Logger;
+
+public class ExceptionUtilsGenerator implements Opcodes {
+ private final static Logger LOGGER = Logger.getLogger(ExceptionUtilsGenerator.class.getName());
+
+ public static void main(String... args) {
+ if (args==null || args.length==0) {
+ throw new IllegalArgumentException("You must specify at least one file");
+ }
+
+ ClassWriter cw = new ClassWriter(0);
+ MethodVisitor mv;
+
+ cw.visit(V1_5, ACC_PUBLIC + ACC_SUPER, "org/codehaus/groovy/runtime/ExceptionUtils", null, "java/lang/Object", null);
+
+ cw.visitSource("ExceptionUtils.java", null);
+
+ mv = cw.visitMethod(ACC_PUBLIC, "<init>", "()V", null, null);
+ mv.visitCode();
+ Label l0 = new Label();
+ mv.visitLabel(l0);
+ mv.visitLineNumber(18, l0);
+ mv.visitVarInsn(ALOAD, 0);
+ mv.visitMethodInsn(INVOKESPECIAL, "java/lang/Object", "<init>", "()V");
+ mv.visitInsn(RETURN);
+ Label l1 = new Label();
+ mv.visitLabel(l1);
+ mv.visitLocalVariable("this", "Lorg/codehaus/groovy/runtime/ExceptionUtils;", null, l0, l1, 0);
+ mv.visitMaxs(1, 1);
+ mv.visitEnd();
+
+ mv = cw.visitMethod(ACC_PUBLIC + ACC_STATIC, "sneakyThrow", "(Ljava/lang/Throwable;)V", null, null);
+ mv.visitCode();
+ Label l2 = new Label();
+ mv.visitLabel(l2);
+ mv.visitLineNumber(20, l2);
+ mv.visitVarInsn(ALOAD, 0);
+ mv.visitInsn(ATHROW);
+ Label l3 = new Label();
+ mv.visitLabel(l3);
+ mv.visitLocalVariable("e", "Ljava/lang/Throwable;", null, l2, l3, 0);
+ mv.visitMaxs(1, 1);
+ mv.visitEnd();
+
+ cw.visitEnd();
+
+ LOGGER.info("Generating ExceptionUtils");
+ byte[] bytes = cw.toByteArray();
+ for (String classFilePath : args) {
+ File classFile = new File(classFilePath);
+ if (classFile.getParentFile().exists() || classFile.getParentFile().mkdirs()) {
+ try {
+ if (classFile.exists()) {
+ classFile.delete();
+ }
+ BufferedOutputStream bos = new BufferedOutputStream(new FileOutputStream(classFile));
+ bos.write(bytes);
+ bos.close();
+ } catch (IOException e) {
+ LOGGER.warning("Unable to write file "+classFile);
+ }
+ } else {
+ LOGGER.warning("Unable to create directory "+classFile.getParentFile());
+ }
+ }
+ }
+}
--
2.14.1