guix/gnu/packages/patches/opencv-rgbd-aarch64-test-fi...

41 lines
1.7 KiB
Diff

https://github.com/opencv/opencv_contrib/commit/8aaa91c3dc835690477d7777e66948dbf5a87edc.patch
From 8aaa91c3dc835690477d7777e66948dbf5a87edc Mon Sep 17 00:00:00 2001
From: Tomoaki Teshima <tomoaki.teshima@gmail.com>
Date: Mon, 5 Nov 2018 20:32:23 +0900
Subject: [PATCH] avoid test failing on Aarch64 * loosen the threshold in
Rgbd_Normals.compute * make the minimum tvec larger in
RGBD_Odometry_Rgbd.algorithmic
---
modules/rgbd/test/test_normal.cpp | 2 +-
modules/rgbd/test/test_odometry.cpp | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/modules/rgbd/test/test_normal.cpp b/modules/rgbd/test/test_normal.cpp
index f2233553a7..ed54f2cd98 100644
--- a/modules/rgbd/test/test_normal.cpp
+++ b/modules/rgbd/test/test_normal.cpp
@@ -211,7 +211,7 @@ class CV_RgbdNormalsTest: public cvtest::BaseTest
std::cout << std::endl << "*** FALS" << std::endl;
errors[0][0] = 0.006f;
errors[0][1] = 0.03f;
- errors[1][0] = 0.00008f;
+ errors[1][0] = 0.0001f;
errors[1][1] = 0.02f;
break;
case 1:
diff --git a/modules/rgbd/test/test_odometry.cpp b/modules/rgbd/test/test_odometry.cpp
index 62b654a1ec..f5a2084504 100644
--- a/modules/rgbd/test/test_odometry.cpp
+++ b/modules/rgbd/test/test_odometry.cpp
@@ -213,7 +213,7 @@ void CV_OdometryTest::generateRandomTransformation(Mat& rvec, Mat& tvec)
normalize(rvec, rvec, rng.uniform(0.007f, maxRotation));
randu(tvec, Scalar(-1000), Scalar(1000));
- normalize(tvec, tvec, rng.uniform(0.007f, maxTranslation));
+ normalize(tvec, tvec, rng.uniform(0.008f, maxTranslation));
}
void CV_OdometryTest::run(int)