guix/gnu/packages/patches/postgresql-disable-resolve_...

26 lines
644 B
Diff

From 223c82d1d6ed1f29f26307249827ff679e09c780 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 28 Jul 2018 12:22:12 +0200
Subject: [PATCH] disable resolve_symlink
---
src/common/exec.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/common/exec.c b/src/common/exec.c
index 878fc29..6b3e283 100644
--- a/src/common/exec.c
+++ b/src/common/exec.c
@@ -218,6 +218,8 @@ find_my_exec(const char *argv0, char *retpath)
static int
resolve_symlinks(char *path)
{
+ // On GuixSD we *want* stuff relative to symlinks.
+ return 0;
#ifdef HAVE_READLINK
struct stat buf;
char orig_wd[MAXPGPATH],
--
2.18.0