guix/gnu/packages/patches/wicd-get-selected-profile-f...

17 lines
532 B
Diff

Fix copied from https://bugs.launchpad.net/wicd/+bug/1421918/comments/2
--- wicd-1.7.3/curses/wicd-curses.py 2014-12-21 16:57:33 +0000
+++ wicd-1.7.3/curses/wicd-curses.py 2015-02-24 23:41:01 +0000
@@ -532,7 +532,10 @@
def get_selected_profile(self):
"""Get the selected wired profile"""
loc = self.get_focus()[1]
- return self.theList[loc]
+ if len(self.theList) > loc:
+ return self.theList[loc]
+ else:
+ return self.theList[-1]
class AdHocDialog(Dialog2):