4463c0d216
* gnu/packages/patches/icecat-CVE-2015-2722-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2722-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt3.patch, gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch, gnu/packages/patches/icecat-CVE-2015-2728-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2728-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch, gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch, gnu/packages/patches/icecat-CVE-2015-2735.patch, gnu/packages/patches/icecat-CVE-2015-2736.patch, gnu/packages/patches/icecat-CVE-2015-2738.patch, gnu/packages/patches/icecat-CVE-2015-2739.patch, gnu/packages/patches/icecat-CVE-2015-2740.patch, gnu/packages/patches/icecat-CVE-2015-2743.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
28 lines
848 B
Diff
28 lines
848 B
Diff
From ecb3805b4425165d35b82874d4f9c55b75fb5390 Mon Sep 17 00:00:00 2001
|
|
From: Ryan VanderMeulen <ryanvm@gmail.com>
|
|
Date: Tue, 9 Jun 2015 12:12:13 -0400
|
|
Subject: [PATCH] Bug 1142210 - Bustage follow-up on a CLOSED TREE.
|
|
|
|
--HG--
|
|
extra : transplant_source : %06B%8EGN%40%985%DC%D5%0E%DD%13%29%8AC%BF%1A%BA%B6
|
|
---
|
|
dom/indexedDB/IndexedDatabaseManager.cpp | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/dom/indexedDB/IndexedDatabaseManager.cpp b/dom/indexedDB/IndexedDatabaseManager.cpp
|
|
index 820dfa6..eabfe09 100644
|
|
--- a/dom/indexedDB/IndexedDatabaseManager.cpp
|
|
+++ b/dom/indexedDB/IndexedDatabaseManager.cpp
|
|
@@ -108,6 +108,8 @@ END_INDEXEDDB_NAMESPACE
|
|
|
|
namespace {
|
|
|
|
+NS_DEFINE_IID(kIDBRequestIID, PRIVATE_IDBREQUEST_IID);
|
|
+
|
|
mozilla::StaticRefPtr<IndexedDatabaseManager> gDBManager;
|
|
|
|
mozilla::Atomic<bool> gInitialized(false);
|
|
--
|
|
2.4.3
|
|
|