b7178dc45d
Actually, CVE-2015-0801 and CVE-2015-0816 were already patched in
4c153a9125
, but the corresponding CVEs
were not yet announced.
* gnu/packages/patches/icecat-bug-1146339.patch: Rename to ...
* gnu/packages/patches/icecat-CVE-2015-0801.patch: ... this.
* gnu/packages/patches/icecat-bug-1144991.patch: Rename to ...
* gnu/packages/patches/icecat-CVE-2015-0816.patch: ... this.
* gnu/packages/patches/icecat-CVE-2015-0807.patch,
gnu/packages/patches/icecat-CVE-2015-0815-pt1.patch,
gnu/packages/patches/icecat-CVE-2015-0815-pt2.patch,
gnu/packages/patches/icecat-CVE-2015-0815-pt3.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them, and adapt to renamed files.
* gnu/packages/gnuzilla.scm (icecat): Add patches, and adapt to renamed files.
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
From e7fc74f6a281c12a4a406f2dd20ff2c27a61484d Mon Sep 17 00:00:00 2001
|
|
From: Brian Hackett <bhackett1024@gmail.com>
|
|
Date: Sun, 8 Mar 2015 22:10:01 -0400
|
|
Subject: [PATCH] Bug 1138199. r=billm, a=lmandel
|
|
|
|
---
|
|
js/src/ds/LifoAlloc.h | 12 ++++++------
|
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/js/src/ds/LifoAlloc.h b/js/src/ds/LifoAlloc.h
|
|
index 7617cf5..b112353 100644
|
|
--- a/js/src/ds/LifoAlloc.h
|
|
+++ b/js/src/ds/LifoAlloc.h
|
|
@@ -193,14 +193,14 @@ class LifoAlloc
|
|
|
|
// Append used chunks to the end of this LifoAlloc. We act as if all the
|
|
// chunks in |this| are used, even if they're not, so memory may be wasted.
|
|
- void appendUsed(BumpChunk *start, BumpChunk *latest, BumpChunk *end) {
|
|
- JS_ASSERT(start && latest && end);
|
|
+ void appendUsed(BumpChunk *otherFirst, BumpChunk *otherLatest, BumpChunk *otherLast) {
|
|
+ JS_ASSERT(otherFirst && otherLatest && otherLast);
|
|
if (last)
|
|
- last->setNext(start);
|
|
+ last->setNext(otherFirst);
|
|
else
|
|
- first = latest = start;
|
|
- last = end;
|
|
- this->latest = latest;
|
|
+ first = otherFirst;
|
|
+ latest = otherLatest;
|
|
+ last = otherLast;
|
|
}
|
|
|
|
void incrementCurSize(size_t size) {
|
|
--
|
|
2.2.1
|
|
|