4c153a9125
* gnu/packages/patches/icecat-CVE-2015-0817.patch, gnu/packages/patches/icecat-CVE-2015-0818-pt1.patch, gnu/packages/patches/icecat-CVE-2015-0818-pt2.patch, gnu/packages/patches/icecat-bug-1127780.patch, gnu/packages/patches/icecat-bug-1144991.patch, gnu/packages/patches/icecat-bug-1145870.patch, gnu/packages/patches/icecat-bug-1146339.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat): Add patches.
29 lines
964 B
Diff
29 lines
964 B
Diff
From 83364c747c421b191f9d4012896a9e5a1d5223ad Mon Sep 17 00:00:00 2001
|
|
From: Kyle Huey <khuey@kylehuey.com>
|
|
Date: Fri, 20 Mar 2015 19:15:13 -0700
|
|
Subject: [PATCH] Bug 1144988. r=bz a=lmandel
|
|
|
|
---
|
|
docshell/base/nsDocShell.cpp | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/docshell/base/nsDocShell.cpp b/docshell/base/nsDocShell.cpp
|
|
index 4cddcef..bdf88a5cf 100644
|
|
--- a/docshell/base/nsDocShell.cpp
|
|
+++ b/docshell/base/nsDocShell.cpp
|
|
@@ -1322,9 +1322,10 @@ nsDocShell::LoadURI(nsIURI * aURI,
|
|
|
|
// Note: we allow loads to get through here even if mFiredUnloadEvent is
|
|
// true; that case will get handled in LoadInternal or LoadHistoryEntry.
|
|
- if (IsPrintingOrPP()) {
|
|
+ if (IsPrintingOrPP() || mBlockNavigation) {
|
|
return NS_OK; // JS may not handle returning of an error code
|
|
}
|
|
+
|
|
nsCOMPtr<nsIURI> referrer;
|
|
nsCOMPtr<nsIInputStream> postStream;
|
|
nsCOMPtr<nsIInputStream> headersStream;
|
|
--
|
|
2.2.1
|
|
|