guix/gnu/packages/patches/coreutils-dummy-man.patch
Ludovic Courtès 7f31c71cb8 gnu: coreutils: Fix cross-compilation issue with 'dummy-man'.
This should work around the bug described at
<http://git.yoctoproject.org/cgit.cgi/poky/plain/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch>.

* gnu/packages/base.scm (coreutils)[patches]: Add
  'coreutils-dummy-man.patch'.
  [native-inputs]: Don't pass PERL when (%current-target-system) is
  true.
* gnu/packages/patches/coreutils-dummy-man.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
2014-02-10 18:27:42 +01:00

18 lines
483 B
Diff

Coreutils commit b3578fc9ffe70b9466687f9f6470a85f1a0ab14f.
* man/dummy-man: Recognize the option --info-page=... as no-op.
This fixes "dummy-man: too many non-option arguments" when
cross-compiling.
--- a/man/dummy-man
+++ b/man/dummy-man
@@ -30,6 +30,7 @@ while test $# -gt 0; do
# in the makefile.
--include=*);;
--include) shift;;
+ --info-page=*);;
-*) fatal_ "invalid or unrecognized help2man option '$1'";;
--) shift; break;;
*) break;;