800cdeef31
* Makefile.am (nobase_dist_guilemodule_DATA): Keep only $(MODULES). (patchdir): New variable. (dist_patch_DATA): New variable. Patch files formerly in $(nobase_dist_guilemodule_DATA). (.scm.go): Define `DISTRO_PATCH_DIRECTORY' and `DISTRO_INSTALLED_PATCH_DIRECTORY'. (TESTS_ENVIRONMENT): Define `DISTRO_PATCH_DIRECTORY'. * distro.scm (%patch-directory): New variable. (search-patch): New procedure. * distro/base.scm: Use `search-patch' instead of `(search-path %load-path ...)'. * distro/findutils-absolute-paths.patch, distro/guile-1.8-cpp-4.5.patch, distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch, distro/make-impure-dirs.patch: Move to `distro/patches'.
25 lines
1010 B
Diff
25 lines
1010 B
Diff
Fix doc snarfing with GCC 4.5+.
|
|
From <http://git.savannah.gnu.org/cgit/guile.git/commit/?h=branch_release-1-8&id=aac41d28358cea594bb30f6e547afb82bb6004a6>.
|
|
|
|
diff --git a/scripts/snarf-check-and-output-texi b/scripts/snarf-check-and-output-texi
|
|
index ea33e17..8cd42e8 100755
|
|
--- a/scripts/snarf-check-and-output-texi
|
|
+++ b/scripts/snarf-check-and-output-texi
|
|
@@ -267,6 +267,17 @@ exec ${GUILE-guile} -l $0 -c "(apply $main (cdr (command-line)))" "$@"
|
|
(set! *file* file)
|
|
(set! *line* line))
|
|
|
|
+ ;; newer gccs like to throw around more location markers into the
|
|
+ ;; preprocessed source; these (hash . hash) bits are what they translate to
|
|
+ ;; in snarfy terms.
|
|
+ (('location ('string . file) ('int . line) ('hash . 'hash))
|
|
+ (set! *file* file)
|
|
+ (set! *line* line))
|
|
+
|
|
+ (('location ('hash . 'hash) ('string . file) ('int . line) ('hash . 'hash))
|
|
+ (set! *file* file)
|
|
+ (set! *line* line))
|
|
+
|
|
(('arglist rest ...)
|
|
(set! *args* (do-arglist rest)))
|