800cdeef31
* Makefile.am (nobase_dist_guilemodule_DATA): Keep only $(MODULES). (patchdir): New variable. (dist_patch_DATA): New variable. Patch files formerly in $(nobase_dist_guilemodule_DATA). (.scm.go): Define `DISTRO_PATCH_DIRECTORY' and `DISTRO_INSTALLED_PATCH_DIRECTORY'. (TESTS_ENVIRONMENT): Define `DISTRO_PATCH_DIRECTORY'. * distro.scm (%patch-directory): New variable. (search-patch): New procedure. * distro/base.scm: Use `search-patch' instead of `(search-path %load-path ...)'. * distro/findutils-absolute-paths.patch, distro/guile-1.8-cpp-4.5.patch, distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch, distro/make-impure-dirs.patch: Move to `distro/patches'.
15 lines
328 B
Diff
15 lines
328 B
Diff
Fails to build with glibc 2.12.1 without this patch.
|
|
|
|
http://lists.gnu.org/archive/html/bug-m4/2010-05/msg00002.html
|
|
|
|
--- a/src/path.c
|
|
+++ b/src/path.c
|
|
@@ -22,6 +22,7 @@
|
|
/* Handling of path search of included files via the builtins "include"
|
|
and "sinclude". */
|
|
|
|
#include "m4.h"
|
|
+#include "sys/stat.h"
|
|
|
|
struct includes
|