guix/gnu/packages/patches/glibc-2.29-supported-locale...

33 lines
1.0 KiB
Diff

This patch is taken from debian's glibc package (generate-supported.mk).
It install the localedata/SUPPORTED file of the glibc. This file lists
all the supported locales of the glibc.
diff --git a/localedata/Makefile b/localedata/Makefile
index 65079f9eb8..14818f84e0 100644
--- a/localedata/Makefile
+++ b/localedata/Makefile
@@ -169,7 +169,8 @@ endif
# Files to install.
install-others := $(addprefix $(inst_i18ndir)/, \
$(addsuffix .gz, $(charmaps)) \
- $(locales))
+ $(locales)) \
+ $(inst_i18ndir)/SUPPORTED
tests: $(objdir)/iconvdata/gconv-modules
@@ -380,6 +381,14 @@ endif
include SUPPORTED
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
+ for locale in $(SUPPORTED-LOCALES); do \
+ [ $$locale = true ] && continue; \
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
+ done
+ $(make-target-directory)
+ $(INSTALL_DATA) LOCALES $@
+
INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES))
INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES))