29a780147d
* gnu/packages/patches/icecat-CVE-2016-1930-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt07.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt08.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt09.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt10.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt11.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt12.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt13.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt14.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt15.patch, gnu/packages/patches/icecat-CVE-2016-1935.patch, gnu/packages/patches/icecat-bug-1146335-pt1.patch, gnu/packages/patches/icecat-bug-1146335-pt2.patch, gnu/packages/patches/icecat-limit-max-buffers-size-for-ANGLE.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
35 lines
1.5 KiB
Diff
35 lines
1.5 KiB
Diff
Copied from: https://hg.mozilla.org/releases/mozilla-esr38/rev/fceff80a84a3
|
|
Security advisory: https://www.mozilla.org/en-US/security/advisories/mfsa2016-01/
|
|
Mozilla Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1230668
|
|
|
|
# HG changeset patch
|
|
# User Wes Kocher <wkocher@mozilla.com>
|
|
# Date 1452542163 28800
|
|
# Node ID fceff80a84a32b68d02abc00486fe6c7b86d545b
|
|
# Parent 8c184c30caa6d16f5ec63cce9a77d16f25d2e57e
|
|
Fix up some rebase errors in bug 1230668 r=me a=bustage
|
|
|
|
diff --git a/layout/style/nsComputedDOMStyle.cpp b/layout/style/nsComputedDOMStyle.cpp
|
|
--- a/layout/style/nsComputedDOMStyle.cpp
|
|
+++ b/layout/style/nsComputedDOMStyle.cpp
|
|
@@ -434,18 +434,16 @@ nsComputedDOMStyle::GetStyleContextForEl
|
|
return nullptr;
|
|
}
|
|
|
|
// XXX the !aElement->IsHTML(nsGkAtoms::area)
|
|
// check is needed due to bug 135040 (to avoid using
|
|
// mPrimaryFrame). Remove it once that's fixed.
|
|
if (!aPseudo && aStyleType == eAll && inDocWithShell &&
|
|
!aElement->IsHTML(nsGkAtoms::area)) {
|
|
- if (!aPseudo && aStyleType == eAll && inDocWithShell &&
|
|
- !aElement->IsHTMLElement(nsGkAtoms::area)) {
|
|
nsIFrame* frame = nsLayoutUtils::GetStyleFrame(aElement);
|
|
if (frame) {
|
|
nsStyleContext* result = frame->StyleContext();
|
|
// Don't use the style context if it was influenced by
|
|
// pseudo-elements, since then it's not the primary style
|
|
// for this element.
|
|
if (!result->HasPseudoElementData()) {
|
|
// this function returns an addrefed style context
|
|
|