rekahsoft-guix/rekahsoft-gnu/packages/patches/terraform-provider-path.patch

17 lines
416 B
Diff

diff --git a/command/init.go b/command/init.go
index 403ca245b..05d98329a 100644
--- a/command/init.go
+++ b/command/init.go
@@ -64,6 +64,11 @@ func (c *InitCommand) Run(args []string) int {
return 1
}
+ val, ok := os.LookupEnv("GUIX_TERRAFORM_PLUGIN_DIR")
+ if ok {
+ flagPluginPath = append(flagPluginPath, val)
+ }
+
if len(flagPluginPath) > 0 {
c.pluginPath = flagPluginPath
c.getPlugins = false