Collin J. Doering
9915757715
Additionally, propagate the GUIX_TERRAFORM_PLUGIN_DIR variable so that only guix installed terraform providers can be used. This has the effect of disabling automatic fetching of terraform providers, which may be inconvenient to those who are not expecting this behavior. On Nix, this is resolved by not using a shim shell script that sets this variable when no terraform providers are installed. This approach doesn't work very well on guix, so in the future separate packages which inherit from the existing terraform packages but do not set this environment variable may be provided.
17 lines
416 B
Diff
17 lines
416 B
Diff
diff --git a/command/init.go b/command/init.go
|
|
index 403ca245b..05d98329a 100644
|
|
--- a/command/init.go
|
|
+++ b/command/init.go
|
|
@@ -64,6 +64,11 @@ func (c *InitCommand) Run(args []string) int {
|
|
return 1
|
|
}
|
|
|
|
+ val, ok := os.LookupEnv("GUIX_TERRAFORM_PLUGIN_DIR")
|
|
+ if ok {
|
|
+ flagPluginPath = append(flagPluginPath, val)
|
|
+ }
|
|
+
|
|
if len(flagPluginPath) > 0 {
|
|
c.pluginPath = flagPluginPath
|
|
c.getPlugins = false
|